# EnerVista Integrator

## Table of contents

| 1 INTRODUCTION | Safety symbols and definitions ................................................................................................. 1 |
|               | For further assistance ............................................................................................................... 1 |
| 2 PRODUCT DESCRIPTION | Introduction ............................................................................................................................... 3 |
|               | Devices supported .................................................................................................................... 4 |
|               | License capacity ..................................................................................................................... 6 |
|               | Modbus device update times and system performance ............................................................ 6 |
|               | Modbus TCP/IP versus Modbus RTU ......................................................................................... 7 |
|               | GE MultiNet or Modbus TCP/IP/RTU bridge .............................................................................. 7 |
|               | Device update times using EnerVista software ...................................................................... 8 |
|               | Conclusion ................................................................................................................................ 10 |
| 3 GENERAL USE | Start EnerVista Integrator ........................................................................................................ 11 |
|               | Add device .................................................................................................................................. 13 |
|               | Add GE device ........................................................................................................................... 13 |
|               | Add generic device .................................................................................................................... 18 |
|               | Import device settings .............................................................................................................. 19 |
|               | Set time-outs and preferences ............................................................................................... 19 |
|               | Display server status .............................................................................................................. 20 |
|               | Monitor in EnerVista Integrator ............................................................................................. 20 |
|               | Monitor in Windows .................................................................................................................. 21 |
|               | Advanced options .................................................................................................................... 22 |
|               | Add generic device .................................................................................................................... 22 |
|               | Add GE Fanuc PLC device ......................................................................................................... 27 |
|               | Delete function codes .............................................................................................................. 27 |
|               | Change a register group name ............................................................................................... 28 |
|               | Export a register group .......................................................................................................... 28 |
|               | Use mnemonics .......................................................................................................................... 29 |
|               | Virtual mnemonics ................................................................................................................... 29 |
| 4 ALARMS AND EVENTS | Introduction ............................................................................................................................... 35 |
|               | Start and stop event logging .................................................................................................. 36 |
|               | Start event logging .................................................................................................................. 36 |
# TABLE OF CONTENTS

Stop event logging .............................................................................................................. 36  
View alarms and events ...................................................................................................... 37  
Toggle automatic updating ............................................................................................... 38  
Filter alarms and events ................................................................................................. 38  
Set default view ................................................................................................................ 39  
Set record number and refresh rate ............................................................................... 43  
Change event type ........................................................................................................... 43  
Acknowledge alarm .......................................................................................................... 43  
Create search criteria ...................................................................................................... 44  
View events in rolling logs .............................................................................................. 45

## 5 WAVEFORMS

Introduction ....................................................................................................................... 47  
Start waveform server ...................................................................................................... 48  
Enable waveform retrieval ............................................................................................... 48  
View COMTRADE waveforms ......................................................................................... 49  
  Set preferences .............................................................................................................. 51  
View phasors .................................................................................................................... 54  
View harmonics ............................................................................................................... 55  
Merge COMTRADE files ................................................................................................. 56  
Resample COMTRADE file .............................................................................................. 59  
Toolbar and buttons ......................................................................................................... 60  
  Toolbar ......................................................................................................................... 60  
  Waveform functions .................................................................................................... 61  
  Phasor window ............................................................................................................. 61

## 6 MAINTENANCE

Troubleshoot using Traffic Logger .................................................................................. 63  
Back up files ..................................................................................................................... 64  
Restore files ....................................................................................................................... 65  
View software version ...................................................................................................... 66  
View and manage software license ................................................................................ 66  
Update software ............................................................................................................... 67  
Manage activation code ................................................................................................... 67  
Transfer software license ............................................................................................... 67  
Uninstall software ............................................................................................................ 69

GLOSSARY

INDEX
EnerVista Integrator

Chapter 1: Introduction

This Instruction Manual outlines how to use EnerVista™ Integrator™ software. For installation, launch, and activation, see the EnerVista Integrator Quickstart Guide. A copy can be found under Start > All Programs > EnerVista INTEGRATOR > Documentation.

This chapter outlines the following:
- Safety information
- Technical support contacts

Safety symbols and definitions

Before attempting to install or use any device, review all safety indicators in its manual and in this document to help prevent injury, equipment damage, or downtime.

The following safety and equipment symbols are used in this document.

- **Danger**: Indicates a hazardous situation which, if not avoided, will result in death or serious injury.
- **Warning**: Indicates a hazardous situation which, if not avoided, could result in death or serious injury.
- **Caution**: Indicates a hazardous situation which, if not avoided, could result in minor or moderate injury.
- **Notice**: Indicates practices not related to personal injury.

For further assistance

For product support, contact the information and call center as follows. Have your software key(s) ready.

GE Grid Solutions
650 Markland Street
Markham, Ontario
Canada L6C 0M1
Worldwide telephone: +1 905 927 7070
Europe/Middle East/Africa telephone: +34 94 485 88 54
North America toll-free: 1 877 547 8630
Fax: +1 905 927 5098
Worldwide e-mail: multilin.tech@ge.com
Europe e-mail: multilin.tech.euro@ge.com
Website: http://www.gegridsolutions.com/multilin
EnerVista Integrator

Chapter 2: Product description

This chapter outlines the following:

- Product description
- Devices supported
- License capacity
- Modbus update times and system performance

Introduction

EnerVista Integrator is a power management control system in the GE EnerVista software line. EnerVista Integrator enables seamless integration with GE Multilin devices for new and existing automation systems through pre-configured memory maps to reduce commissioning time and effort. It integrates the comprehensive line of POWER LEADER devices, as well as many Modbus remote terminal unit (RTU) devices. EnerVista Integrator software is the heart of your system, with state-of-the-art graphics and features designed to maximize productivity and minimize downtime and energy costs.

EnerVista Integrator is a suite of software and a database. There are servers for events and waveforms, for example. The database to store information is Microsoft SQL Server 2012 Express or Microsoft SQL Server 2012. You use EnerVista Integrator to monitor devices using alarms, events, and waveforms.

This instruction manual outlines how to use EnerVista Integrator and advanced configuration, including the following procedures:

- Add a GE Multilin Modbus RTU/TCP/IP device to EnerVista Integrator
- View device-generated alarms and events
- View waveforms from a device, when supported by the device

The following figure shows a system that combines all base elements of an EnerVista Integrator system. It includes the following elements: Modbus RTU and Modbus TCP/IP devices; GE MultiNet gateway; GE MultiLink Ethernet switch; and a computer running EnerVista Integrator.
Devices supported

EnerVista Integrator supports the following GE devices.

Table 1: GE devices supported

<table>
<thead>
<tr>
<th>Device family</th>
<th>Device</th>
<th>Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATS</td>
<td>MX150</td>
<td>5.4x, 6.0x</td>
</tr>
<tr>
<td></td>
<td>MX250</td>
<td>5.4x, 6.0x</td>
</tr>
<tr>
<td></td>
<td>MX350</td>
<td>1.2x</td>
</tr>
<tr>
<td>Bay Protection/</td>
<td>C30</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td>Specialized</td>
<td>C60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>C90+</td>
<td>1.6x to 1.8x</td>
</tr>
<tr>
<td></td>
<td>U90+</td>
<td>1.1</td>
</tr>
<tr>
<td>Bus</td>
<td>B30</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>B90</td>
<td>1.8x to 7.3x</td>
</tr>
<tr>
<td>Distribution Feeder</td>
<td>SR3 350</td>
<td>1.2x to 2.0x</td>
</tr>
<tr>
<td></td>
<td>F35</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>F60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>F650</td>
<td>1.6x to 7.1x</td>
</tr>
<tr>
<td></td>
<td>MIF 2</td>
<td>4.0</td>
</tr>
<tr>
<td></td>
<td>735/737</td>
<td>1.5x</td>
</tr>
<tr>
<td></td>
<td>750/760</td>
<td>3.6x to 7.4x</td>
</tr>
<tr>
<td></td>
<td>G30</td>
<td>4.4x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>G60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>8 Series 850</td>
<td>1.0x to 1.6x</td>
</tr>
<tr>
<td>Generator</td>
<td>489</td>
<td>1.3x to 4.03x</td>
</tr>
<tr>
<td></td>
<td>889</td>
<td>1.6x</td>
</tr>
<tr>
<td>Device family</td>
<td>Device</td>
<td>Firmware</td>
</tr>
<tr>
<td>------------------</td>
<td>----------</td>
<td>------------</td>
</tr>
<tr>
<td>Line Protection</td>
<td>D30</td>
<td>3.0x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>D60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>D90+</td>
<td>1.8x</td>
</tr>
<tr>
<td></td>
<td>L30</td>
<td>5.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>L60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>L90</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td>Meters/Switches</td>
<td>PQM</td>
<td>3.3x to 3.6x</td>
</tr>
<tr>
<td></td>
<td>PQMII</td>
<td>1.0x to 2.2x</td>
</tr>
<tr>
<td></td>
<td>EPM 1000</td>
<td>3.8x</td>
</tr>
<tr>
<td></td>
<td>EPM 2000</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 2200</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 4000</td>
<td>3.8x</td>
</tr>
<tr>
<td></td>
<td>EPM 4600S</td>
<td>3.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 4600T</td>
<td>3.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 6000</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 6000T</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 6010</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 6100</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 7000</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 7000T</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 7100</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>EPM 9450Q</td>
<td>2.1x</td>
</tr>
<tr>
<td></td>
<td>EPM 9650Q</td>
<td>2.1x</td>
</tr>
<tr>
<td></td>
<td>EPM 9800</td>
<td>6.1x</td>
</tr>
<tr>
<td></td>
<td>EPM 9900</td>
<td>1.0x</td>
</tr>
<tr>
<td></td>
<td>MultiNet ML2400</td>
<td>3.0x</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>FIRETRACER</td>
<td>1.0</td>
</tr>
<tr>
<td></td>
<td>VERSAMAX</td>
<td>1.0</td>
</tr>
<tr>
<td>Monitoring/Remote I/O</td>
<td>DGCM</td>
<td>4.0x</td>
</tr>
<tr>
<td>Motor</td>
<td>239</td>
<td>2.3x to 2.7x</td>
</tr>
<tr>
<td></td>
<td>269+</td>
<td>6.0x</td>
</tr>
<tr>
<td></td>
<td>SR3 339</td>
<td>1.3x to 1.7x</td>
</tr>
<tr>
<td></td>
<td>369</td>
<td>1.6x to 3.6x</td>
</tr>
<tr>
<td></td>
<td>469</td>
<td>2.5x to 5.2x</td>
</tr>
<tr>
<td></td>
<td>869</td>
<td>1.3x to 1.60x</td>
</tr>
<tr>
<td></td>
<td>MM200</td>
<td>1.0x to 1.2x</td>
</tr>
<tr>
<td></td>
<td>MM300</td>
<td>1.2x to 1.70</td>
</tr>
<tr>
<td></td>
<td>MMIII</td>
<td>4.0x to 5.2x</td>
</tr>
<tr>
<td></td>
<td>MMIII</td>
<td>1.0 to 1.2x</td>
</tr>
<tr>
<td></td>
<td>RRTD</td>
<td>1.4x, 1.5x</td>
</tr>
<tr>
<td></td>
<td>SPM</td>
<td>2.0x, 2.1x</td>
</tr>
<tr>
<td></td>
<td>M60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td>Network</td>
<td>N60</td>
<td>3.4x to 7.3x</td>
</tr>
</tbody>
</table>
License capacity

The number of devices and data points supported depend on the software license purchased, as follows:

- 100 devices / 5,000 points
- 300 devices / 30,000 points
- 500 devices / 65,000 points
- 1,000 devices / 20,000 points

The installed capacity can be viewed under Help > License Management. The point limit also displays at the top of the Device Setup window.

<table>
<thead>
<tr>
<th>Device family</th>
<th>Device</th>
<th>Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transformer</td>
<td>745</td>
<td>2.4x to 5.2x</td>
</tr>
<tr>
<td></td>
<td>T35</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>T60</td>
<td>2.6x to 7.3x</td>
</tr>
<tr>
<td></td>
<td>345</td>
<td>1.3x to 1.5x</td>
</tr>
<tr>
<td></td>
<td>845</td>
<td>1.40x to 1.6x</td>
</tr>
<tr>
<td>Trip Units/Switchgear</td>
<td>Spectra MicroVersa Trip</td>
<td>5.1x</td>
</tr>
<tr>
<td></td>
<td>Enhanced MicroVersa Trip C</td>
<td>4.1x</td>
</tr>
<tr>
<td></td>
<td>Enhanced MicroVersa Trip D</td>
<td>4.1x</td>
</tr>
<tr>
<td></td>
<td>GTU (EntelliGuard TU Trip Unit)</td>
<td>7.0x</td>
</tr>
<tr>
<td></td>
<td>ELVS (Entellisys)</td>
<td>6.0x to 5.0x</td>
</tr>
<tr>
<td></td>
<td>MET</td>
<td>12.02.02</td>
</tr>
<tr>
<td>UPS</td>
<td>UPS, UPS LP, UPS SG</td>
<td>1.0</td>
</tr>
</tbody>
</table>

License capacity

Licenses can be upgraded.

Each software license allows for installation on one computer. To install the software on multiple computers, you need a license key for each computer. The software supports multiple installations from different network locations, with each installation having its respective communication, event, and waveform server performing data collection.

Modbus device update times and system performance

This section outlines the Modbus protocol and provides examples of balancing network configuration with data update times.
The Modbus protocol is a master/slave transaction where a master device generates a query and a slave device generates a response. A slave gives a response only when queried by the master. The time it takes for the device to answer is the "device response time." The "device update time" is how quickly a queried data set is updated in the master for that specific device.

Internal processing of the Modbus command by the device takes up the majority of the device response time. Network baud rates (both serial and Ethernet) account for only a small percentage of the device response time.

The nature of Modbus is that only one device can be queried at a time on the same network. For the Modbus RTU protocol, the “same network” is defined as a specific serial line (RS485/232) and all devices on that line. For Modbus TCP/IP, the “same network” is defined as a specific IP address (UR, MultiNet, and so on) and the IP port associated with that IP address.

When there is one device on the "same network," the "device response time" and the "device update time" are roughly equal.

When there are multiple devices on the "same network," the master must query them one at a time. For example, a network has devices A, B, and C, and the master needs data from all three devices. If each device has a "device update time" of one second, the master sees fresh data from each device every three seconds (1 + 1 + 1 = 3). The more devices on the network, the longer each "device update time." The more devices on a serial line, the longer the overall device update time on that line (assuming each device is polled for data).

A complete update cycle on the same network is referred to as “round-robin time.”

### Modbus TCP/IP versus Modbus RTU

Performance is almost identical, but Modbus TCP/IP has advantages.

Many people assume that Modbus TCP/IP is faster than Modbus RTU due to the fact that it runs on Ethernet or a TCP/IP network. However, because Modbus TCP/IP follows the same rules as Modbus RTU, the device update performance is almost identical. The advantage of using Modbus TCP/IP is related to ease of transport. Use of Ethernet is now almost ubiquitous and allows easier support compared to a traditional RS485 network. Both hardware and installation of an Ethernet network are cheaper than serial connections and can be maintained by a facilities networking group. It also allows flexibility in data access via intra/inter/extranets. Another advantage is that a device with embedded Modbus TCP/IP is configured in the Modbus master as a single device on the same network. As explained, a single device on a single network (serial or IP) has no "round-robin time" associated with having multiple devices on the same network. Thus a dedicated Modbus TCP/IP device gives the appearance of a performance gain, but this is derived solely from the virtue of being a single device on the network. A serial Modbus RTU device has similar update performance when alone on a serial line.

### GE MultiNet or Modbus TCP/IP/RTU bridge

With the industry moving toward Modbus TCP/IP devices and Ethernet in general there is a need for legacy support of Modbus RTU and RS485 networks. To support these networks and devices, a Modbus TCP/IP/RTU bridge, such as the GE Multilin MultiNet is required. The MultiNet converts the Modbus RTU protocol to the Modbus TCP/IP protocol. Once converted to Modbus TCP/IP, the messages are passed on using the available TCP/IP network (Ethernet, fiber, and so on).

The biggest difference between a dedicated Modbus TCP/IP device (such as the UR) and a MultiNet is that the MultiNet can have multiple devices daisy-chained on its RS485 port. These multi-dropped devices follow the same rule as other multiple devices on the "same
network.” If each device is polled for data, a “round robin” occurs. The update time is then controlled by the number of devices and how many Modbus blocks are needed from each one.

The following figure illustrates a setup with one meter and three relays. If each device is polled for registers requiring four separate Modbus blocks, then each device takes 1,000 ms to poll (4 x 250 ms/block). Since there are four devices, the total update time is 4,000 ms (device1 + device2 + device3 + device4 = 4,000 ms).

![Figure 3: Example of configuration with one meter and three relays](image)

Device update times using EnerVista software

EnerVista Integrator software can communicate with a range of GE devices, from relays, trip/breaker units, motor controllers, and meters. Each device has a unique register map and number of registers.

When a client requests data from the EnerVista Modbus server, the server processes the request and creates a Modbus request(s) for the required registers. If all the registers required can fit into one Modbus return message (124 registers in sequential order), then only one request for one block of data is made. With only one request needed, the GE device update time is roughly 250 ms.

When the amount of registers is too great for one return message or the registers needed are more than 122 registers apart, then the server breaks the request into two or more Modbus requests requiring two or more blocks of data. Devices with small register maps, such as an MVT trip unit, generally need only one Modbus request with a device response time of about 500 ms (the MVT has a longer device response time than most devices and takes 500 ms to process and return a request). But larger devices (PQM, UR, ML750, and so on) can require four, five, six, or more Modbus requests with a device response time that can be as much as three seconds. To poll the entire register map of a UR can take over six seconds, requiring over 24 Modbus requests. The device update cycle time is, largely, independent of the physical network. A single device on a 19.2 K baud serial line has roughly the same update time as a single device on Ethernet.

The EnerVista Modbus master supports each network independent of other networks. So what happens on network A does not affect what happens on network B. The network is defined as a specific serial line or IP (and its IP port) address. If network A has only one device on it and only one register block is needed, then the data update time is 250 ms. If network B has four devices on it requiring a single block from each, then the “round robin time” is 1,000 ms.

EnerVista Integrator also supports polling of the device alarm/event registers and the oscillography registers. These registers are polled constantly along with any other device registers. If a new device alarm/event or waveform is detected in the device (this condition is monitored via dedicated registers), the EnerVista software then initiates an auto download of the required data. This data is interleaved with the real-time data request so
that the impact on performance is minimized. New alarm/events can be downloaded quickly, while waveforms can take up to 10 minutes to download, depending on the device and waveform settings.

A test case follows. ML refers to Multilin.

Table 2: Configuration example

<table>
<thead>
<tr>
<th>Network</th>
<th>Device 1</th>
<th>Device 2</th>
<th>Device 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>MultiNet 1.1.1</td>
<td>MLPQM</td>
<td>MLPQM</td>
<td>ML750</td>
</tr>
<tr>
<td>UR 1.1.1.2</td>
<td>F60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MultiNet 1.1.1.3</td>
<td>ML750</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ML750 1.1.1.4, with built-in Modbus TCP/IP</td>
<td>ML750</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 4: Example of configuration with multiple devices

Data needed for each MLPQM — Each PQM requires five Modbus requests for the required data, shown in the following table.

Table 3: MLPQM requests

<table>
<thead>
<tr>
<th>PQM mnemonic</th>
<th>Register address (Hex)</th>
<th>Register address (decimal)</th>
<th>Register block</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMS_AVG</td>
<td>R3X0243</td>
<td>579</td>
<td>Block 1 (both with 124 registers)</td>
</tr>
<tr>
<td>VOLTS_AVG_LINE</td>
<td>R3X028EL</td>
<td>654</td>
<td>Block 2</td>
</tr>
<tr>
<td>KW</td>
<td>R3X02F0L</td>
<td>752</td>
<td>Block 3 (both with 124 registers)</td>
</tr>
<tr>
<td>KW_DVIND</td>
<td>R3X0404L</td>
<td>1028</td>
<td>Block 4</td>
</tr>
<tr>
<td>FREQUENCY</td>
<td>R3X0441</td>
<td>1089</td>
<td>Block 5</td>
</tr>
<tr>
<td>New waveform</td>
<td>R3X0B83</td>
<td>2947</td>
<td></td>
</tr>
<tr>
<td>New alarm/event</td>
<td>R3X0AD0</td>
<td>2768</td>
<td></td>
</tr>
</tbody>
</table>

Data needed for each ML750 — Assume that an ML750 requires six Modbus requests for the required data.

Data needed for the F60 — Assume that the F60 requires eight Modbus requests for the required data.

Assumption — Each block takes 250 ms to retrieve.

The performance calculation is as follows.
PQM is 5 blocks x 250 ms = 1,250 ms
ML750 is 6 blocks x 250 ms = 1,500 ms
F60 is 8 blocks x 250 ms = 2,000 ms

Table 4: Example of update times

<table>
<thead>
<tr>
<th>Network</th>
<th>Device 1</th>
<th>Device 2</th>
<th>Device 3</th>
<th>Device update time</th>
</tr>
</thead>
<tbody>
<tr>
<td>MultiNet 1.1.1.1</td>
<td>1,250 ms</td>
<td>1,250 ms</td>
<td>1,500 ms</td>
<td>4,000 ms</td>
</tr>
<tr>
<td>UR 1.1.1.2</td>
<td>2,000 ms</td>
<td></td>
<td></td>
<td>2,000 ms</td>
</tr>
<tr>
<td>MultiNet 1.1.1.3</td>
<td>1,500 ms</td>
<td></td>
<td></td>
<td>1,500 ms</td>
</tr>
<tr>
<td>ML750 1.1.1.4, with built-in Modbus TCP/IP</td>
<td>1,500 ms</td>
<td></td>
<td></td>
<td>1,500 ms</td>
</tr>
</tbody>
</table>

Updates below one second can only be achieved for systems running a dedicated master requesting a constant one or two Modbus blocks from a single device on a network. This is a highly customized function that requires careful planning and design.

**Conclusion**

Before any network is designed or constructed, a careful examination of needed data update performance must be done. Each site and customer is unique. Some customers require data refresh times in the tens of seconds while others require less than a second. Any update requirement within the physical confines of Modbus can be done but requires correct network layout and knowledge of what specific data is needed from each specific device type. Users must be aware that use of Modbus TCP/IP with Ethernet does not itself increase performance to a noticeable extent. The critical factors are the number of devices on the same network and how much is polled from each device.
EnerVista Integrator

Chapter 3: General use

This chapter outlines functions of the system, as follows:

- Start EnerVista Integrator
- Add a GE device or a generic device
- Set time-outs and preferences
- Display server status
- Advanced configuration

Start EnerVista Integrator

To start the software:

1. Click Start > All Programs > EnerVista INTEGRATOR > EnerVista Integrator Configurator or the desktop shortcut. The software launches. The figure shows the menu options, which are explained in the following table.
2. If the Unlock Now button displays in the window, it means that the activation code has not been entered for the software license. Follow the instructions in the EnerVista Integrator Quickstart Guide to enter the activation code.

<table>
<thead>
<tr>
<th>Menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Setup</td>
<td>Add and configure devices and communication</td>
</tr>
<tr>
<td>Events</td>
<td>Configure and view the alarms and event records of devices</td>
</tr>
<tr>
<td>Waveforms</td>
<td>View COMTRADE formatted images and data</td>
</tr>
<tr>
<td>Device Type Info</td>
<td>Advanced options to add generic devices and to modify the mnemonics and register groups for supported devices</td>
</tr>
</tbody>
</table>
Add device

Use the Device Setup and Device Type Info windows to add, update, and delete devices in EnerVista Integrator. The maximum number of devices that can be configured is based on the license, as well as whether the devices are serial or Ethernet types. Devices can be added within an existing site or separately. When done, the Device Setup window shows sites (Ethernet and serial) or devices that you have previously set up, which allows you to export setup files and import them for similar devices.

This section outlines how to:
- Add a GE device
- Add a generic device
- Import device settings

Add GE device

For a list of GE devices supported, see the table in the Devices supported section on page 4 or in the Quickstart Guide.

Devices connected over serial and Ethernet interfaces can be configured as follows:
- Serial — Devices using Modbus RTU accessed via communications ports connected to a RS232 or RS485 line. Examples are the PQM, SR750, and MicroVersaTrip.
- Ethernet — Devices using Modbus TCP/IP over Ethernet or fiber. Examples are devices with a Modbus TCP/IP option, such as the UR or EPM 9650, and serial devices using a Modbus TCP/RTU bridge, such as a MultiTin MultiNet.

Devices accessed via Ethernet port servers, such as the GE POWER LEADER Ethernet Gateway, are considered serial, as the port server serial ports are mapped as communication ports in the computer.

If in doubt about whether a device uses a serial or Ethernet connection, simply try adding it as one and then the other.
To add a GE device connected in serial:

1. Click the **Device Setup** option in the main window. A prompt displays that any connected devices are disconnected when opening the window; acknowledge and continue. The Device Setup window opens.

2. Click to expand the **Serial** category on the left side if not already active.

3. Click the **Add Device** button. The right side of the window populates with serial device information.

4. Enter the device information as follows.
   - **Device Name** — The name of the GE or third-party device, such as D60 or MM300_Markham. The name is up to 20 characters, must start with a letter, and contain no special characters or spaces. If a space is required, use an underscore "_".
   - **Description** — Optional. Appears here only.
   - **Interface** — A **Serial** interface card is used to communicate with the device. **Serial** is reserved for devices using Modbus RTU accessed via COM ports connected to a RS232/485 line. Examples are the PQM, SR750, and MicroVersaTrip. Devices accessed via Ethernet Port Servers, such as the GE POWER LEADER Ethernet Gateway, are considered serial, as the port server serial ports are mapped as COM ports in the computer.
   - **Events** — The check box can become active after selection of the **Device type**. Enables retrieval of event records from a device supporting this function. When enabled, the device is polled continuously for new events. When a new event is found in the device, it is downloaded automatically by the system and available for display in the Event Viewer.
Waveforms — The check box can become active after selection of the Device type. Enables retrieval of waveforms from a device supporting this function. When enabled, the device is polled continuously for new waveforms. When a new waveform is found in the device, it is downloaded automatically by the system and available for display in the Waveform Viewer.

TimeDownload — The check box can become active after selection of the Device type. Enable to synchronize the system (computer) time with the device time whenever the system starts and at regular intervals as configured.

TFTP supported — The check box can become active after selection of the Device type. Enable to retrieve events and waveforms using the trivial file transfer protocol (TFTP) if the device has TFTP support, else it retrieves via Modbus (depends on the device configuration).

PMU — The check box can become active after selection of the Device type. Enables retrieval of Phasor Measurement Unit (PMU) data, provided that the device supports PMU.

Slave address — The ID of the device for Modbus communication. Multiple devices on the same COM port or IP address (when using a MultiNet) must have unique slave addresses. Each slave in the network is assigned a unique address/ID, so use the number already assigned to it here. The range is 1 to 254. Multiple devices on the same COM port or IP address (when using a MultiNet) must have unique slave addresses. See the instruction manual of the device to determine what the likely slave address is. Or look it up in the EnerVista software of the device.

COM port — The computer COM port used to communicate with the device. The number of devices on the RS485 segment dictates the update performance. The more devices, the slower the data updates. Look up the port number in the EnerVista software of the device.

Baud Rate — The baud rate for the COM port selected. Baud rates for the COM port and all devices on the COM port must match. Look it up in the EnerVista software of the device.

Parity — Must match device and COM port settings for the COM port and all devices on the COM port. Look it up in the EnerVista software of the device.

Bits — Must match device and COM port settings for the COM port and all devices on the COM port.

Stop Bits — Must match device and COM port settings for the COM port and all devices on the COM port.

Device type — Select the device from the drop-down list.

Devices belonging to the UR series, other than the B90, are categorized as the following types:

UR — Supports UR 2.6x to 4.6x
UR480 — Supports UR 4.8x
UR490 — Supports UR 4.9x and 5.0x
UR520 — Supports UR 5.2x
UR540 — Supports UR 5.4x
UR550 — Supports UR 5.5x to 6.0x
UR700 — Supports UR 7.0x to 7.3x

For B90 devices

B90 — Supports B90 4.8x to 5.0x
B90_520 — Supports B90 5.2x
B90_540 — Supports B90 5.4x
B90_550 — Supports B90 5.5x to 6.0x
B90_700 — Supports B90 7.0x to 7.3x
For 8 Series devices
850 — Supports 850 1.0x to 1.1x
850_120 — Supports 850 1.2x to 1.3x
850_140 — Supports 850 1.4x to 1.6x
869 — Supports 869 1.3x
860_140 — Supports 869 1.4x to 1.6x
845 — Supports 845 1.4x to 1.6x
889 — Supports 889 1.6x

5. Click the Test Communication button to ensure that the software can communicate with the device. A green LED appears with success, and a red LED appears with failure, such as the device being offline or not powered up.

6. Click OK to add the device. The EnerVista Integrator software automatically launches the server applications, such as WFServer and EventServer based on the configuration.

---

Figure 8: Device Setup window for Ethernet

To add a GE device connected by Ethernet:

1. Click the Device Setup option in the main window. A prompt displays that any connected devices are disconnected when opening the window; acknowledge and continue. The Device Setup window opens.

2. Click to expand the Ethernet category on the left side.

3. Click the Add Device button. The right side of the window populates with Ethernet device information.
4. Enter the device information, explained as follows.

**Device Name** — The name of the GE or third-party device, such as D60 or MM300_Markham. The name is up to 20 characters, must start with a letter, and contain no special characters or spaces. If a space is required, use an underscore "_".

**Description** — Optional. Appears here only.

**Interface** — An Ethernet card is used to communicate with the device. Ethernet is reserved for devices using Modbus TCP/IP over Ethernet, fiber, and so on. Examples are devices with a Modbus TCP/IP option, such as the UR, EPM 9650, or serial devices using a Modbus TCP/RTU bridge, such as the Multilin MultiNet.

**Events** — The check box can become active after selection of the **Device type**. Enables retrieval of event records from a device supporting this function. When enabled, the device is polled continuously for new events. When a new event is found in the device, it is downloaded automatically by the system and available for display in the Event Viewer.

**Waveforms** — The check box can become active after selection of the **Device type**. Enables retrieval of waveforms from a device supporting this function. When enabled, the device is polled continuously for new waveforms. When a new waveform is found in the device, it is downloaded automatically by the system and available for display in the Waveform Viewer.

**TimeDownload** — The check box can become active after selection of the **Device type**. Enable to synchronize the system (computer) time with the device time whenever the system starts and at regular intervals as configured.

**TFTP supported** — The check box can become active after selection of the **Device type**. Enable to retrieve events and waveforms using TFTP if the device has TFTP support, else it retrieves via Modbus (depends on the device configuration).

**PMU** — The check box can become active after selection of the **Device type**. Enables retrieval of Phasor Measurement Unit (PMU) data, provided that the device supports PMU.

**IP address** — The IP address of the device or Multilin MultiNet Modbus bridge. Look on the front panel of the device or in the device software for its IP address. For a Multilin MultiNet, each device has the same IP address (that of the MultiNet) and Modbus Port number, but each device on the same MultiNet must have a unique Modbus Slave address. When using a MultiNet gateway, be aware that the number of devices on the RS485 segment dictates the update performance. The more devices, the slower the data updates.

**Slave address** — The ID of the device for Modbus communication. Multiple devices on the same COM port or IP address (when using a MultiNet) must have unique slave addresses. Each slave in the network is assigned a unique address/ID, so use the number already assigned to it here. The range is 1 to 254. Multiple devices on the same COM port or IP address (when using a MultiNet) must have unique slave addresses. See the instruction manual of the device to determine what the likely slave address is.

**Modbus port** — The port number used for Modbus communication within the system. The range is 1 to 65535, and the standard Modbus TCP port is 502. The devices likely listen on that port. The port number here needs to be same as that used by all devices. See the instruction manual of the device to determine the likely port number.

**Device type** — Select the device from the drop-down list.

Devices belonging to the UR series, other than the B90, are categorized as the following types:

- **UR** — Supports UR 2.6x to 4.6x
- **UR480** — Supports UR 4.8x
- **UR490** — Supports UR 4.9x and 5.0x
UR520 — Supports UR 5.2x
UR540 — Supports UR 5.4x
UR550 — Supports UR 5.5x to 6.0x
UR700 — Supports UR 7.0x to 7.3x

For B90 devices
B90 — Supports B90 4.8x to 5.0x
B90_520 — Supports B90 5.2x
B90_540 — Supports B90 5.4x
B90_550 — Supports B90 5.5x to 6.0x
B90_700 — Supports B90 7.0x to 7.3x

For 8 Series devices
850 — Supports 850 1.0x to 1.1x
850_120 — Supports 850 1.2x to 1.3x
850_140 — Supports 850 1.4x to 1.6x
869 — Supports 869 1.3x
860_140 — Supports 869 1.4x to 1.6x
845 — Supports 845 1.4x to 1.6x
889 — Supports 889 1.6x

Connected via Ethernet Gateway — When the device is connected via Ethernet gateway this option must be enabled. This helps in optimizing the request flow to the devices configured on MultiNet. If devices are on a MultiNet this option is enabled (determined by validating same IP address with different slave IDs). This option is provided as MultiNets tend to be slower in responding than the devices with a dedicated communication channel.

5. Click the Test Communication button to ensure that the software can communicate with the device. A green LED appears with success, and a red LED appears with failure, such as the device being offline or not powered up.

6. Click OK to add the device. The EnerVista Integrator software automatically launches the server applications, such as WFServer and EventServer based on the configuration.

Add generic device
The Device Type Info option on the main window is an advanced feature for adding generic devices.
To add a generic device:
1. See the Add generic device section on page 22.

Import device settings
Once devices have been added, the setup files can be exported, then imported to add similar devices. You export the Register Group and optionally any mnemonic files. See the import and export steps, for example in the Export a register group and Use mnemonics sections later in the chapter.
Set time-outs and preferences

Default options can be changed.

To set time-outs and preferences:

1. Click **File > Preferences**. The window opens.

   **Figure 9: Preferences window**

   ![Preferences window]

2. Set the preferences as follows.

   **Dead Device Scan Interval** — The interval at which non-responsive devices are polled. Once a device is declared DEAD, the communication server retries/rescans the device after this interval. Measured in milliseconds, the default is 60,000 ms, which is one minute.

   **Communication Timeout** — Determines the amount of time that the communication server has to wait after sending a request to determine that the communication has failed/timed-out. Measured in milliseconds. The default is 3,000 ms, which is three seconds.

   **Maximum Query Retries** — The number of times that a request has to be retried before declaring a device DEAD (unresponsive). The default is three times.

   **Slow Poll Multiplier** — The polling speed is reduced by this amount for items/mnemonics in slow poll register groups.

   **Timeout for Multinet Devices / Serial** — As MultiNet/serial devices tend to respond slower than devices configured on Ethernet/dedicated communication channels, the communication time-out is set separately for these devices to avoid an unnecessary DEAD state for these devices.

   **Event Archival Timeout** — The device/system events are archived from the database into .csv files and stored on hard disk. This setting determines the maximum duration an event is retained in the database, measured in days. The default is 30 days, which means that events stored in database more than 30 days are deleted and saved in csv files that are archived. Select a time-out interval of 30, 90, 180 or 365 days from the drop-down list. The system events also get archived daily at midnight, and this
interval is not configurable. The archived system event files are deleted after a maximum of 10 days. The archived device event files are deleted after a maximum of one year. These two intervals are not configurable.

3. Click the Ok button to save and exit. Acknowledge at the prompt that the EnerVista Integrator servers restart.

Display server status

There are two ways to monitor, start, and stop the servers of EnerVista Integrator:

- EnerVista Integrator system status window
- In Windows

Monitor in EnerVista Integrator

An EnerVista icon displays on the Windows taskbar, typically at the bottom right of the computer screen. It provides access to an EnerVista status window.

This is a tool to access the server applications. It launches automatically at software start-up and is available in the icon tray on the taskbar. GE recommends leaving this window open, so that you can quickly see which functions are running or not.

Also use this function if EnerVista Integrator or any of its servers is non-responsive, as outlined.

![Status window accessible from Windows taskbar](image)

To view status:

1. Double-click the icon on the Windows taskbar. If the icon is not displayed, click the up arrow on the taskbar, select Customize, and set the EnerVista System Status to show the icon and notifications. If that is not possible, launch the window by clicking the EISystemStatus.exe file, for example at C:\Program Files (x86)\Enervista\EnerVista Integrator\EISystemStatus.exe

![EnerVista icon on taskbar](image)

The table explains the states displayed.
Table 6: Status descriptions

<table>
<thead>
<tr>
<th>Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red</td>
<td>The application is not running and the State displays as Closed</td>
</tr>
<tr>
<td>Yellow</td>
<td>The application is launched and is in a Stopped State. The corresponding server application is not online with devices.</td>
</tr>
<tr>
<td>Green</td>
<td>The application is started and is online with devices</td>
</tr>
</tbody>
</table>

2. To view more information, click the **Performance Metrics** button. The loads and other statistics display.

**Figure 12: EnerVista Integrator statistics**

Exit from this window by clicking the X at the top right.

3. Click the **Minimize** button to close the window and display the icon on the taskbar.

To restart EnerVista Integrator or servers:

1. Access the system status window as outlined, close one or all servers as appropriate, Re-launch EnerVista Integrator as appropriate.

**Monitor in Windows**

The EnerVista Integrator servers can be checked, started, and stopped in the Windows Component Services. To monitor functions using Windows:

1. Click **Start > Control Panel**, access **Administrative Tools**, then **Component Services**. Allow access at the prompt. The window opens.
2. Click or expand the **Services (Local)** entry on the left.
3. Scroll to the EnerVista entries.
4. Select an entry and note that you can start or stop the service, as well as double-click the entry to set startup behavior. In the example shown here, the waveform server WFServer is invoked manually by the user and does not start up automatically.
Advanced options

Advanced options include the following:

- Add generic device
- Add GE Fanuc Programmable Logic Controller (PLC) device
- Delete function codes
- Change a register group name
- Export a register group
- Use mnemonics

**NOTICE**

These advanced options are for experts only. If you make a mistake, it is possible to render some functions inoperable, forcing you to reinstall and lose device setup configuration. Read all instructions before attempting.

Add generic device

EnerVista Integrator is pre-configured to support the GE Multilin family of power-management devices, as well as a variety of third-party devices. You can also add additional devices by creating your own device type. These “generic” devices have the register maps and functions that you assign, as outlined here. The generic device type does not support special device handling, such as automatic time synchronization, waveform capability, or event handling.
When adding the device information, there are two ways to add the memory map: manually or import. You can import a comma-separated values (.csv) file. Prepare the CSV file before starting if you intend to import.

To add a generic device:

1. In the main EnerVista Integrator window, click the **Device Type Info** option. The window opens.

2. At the bottom of the window, type a group/device type name, such as Generic, then click the **Add Default Type** button. Names can be up to 20 alphanumeric characters long and cannot include embedded spaces or special characters, such as + * / , ? ! " " . This adds the new device type to the list of Configured Device Types.

![Figure 14: Add generic device type](image)

3. Add the function codes for the device by selecting the device type in the list and clicking the **Function Codes** button. You need the device’s Modbus RTU protocol to know which codes to add.
The Available Function Codes are the function codes available to any generic device type, where function codes are standard codes supported by the Modbus standard, such as:

- 01 Read Coil Status
- 02 Read Input Status
- 03 Read Holding Registers
- 04 Read Input Registers
- 05 Force Single Coil

The Selected Function Codes are the function codes to be assigned. Select and place the required function codes into the Selected Function Codes box using the Add and Delete buttons, then click the OK button to save and close.

In the Device Types window, add the register map for the device by selecting the device type in the list and clicking the Register Map button. The Register Map window opens. Be careful not to modify or delete the Register Map for pre-configured devices. Only generic devices and PLC type-devices are intended to have any modifications to their Register Groups.
5. In the Register Map window, note that you manually add the map (Add button) or import the map (Import Register Group button). When importing, enter the .csv file name at the prompt and skip the rest of this procedure. When manually adding, the Select Register Group Type window opens; continue with the rest of this procedure.

6. Enter the Register Group name, which can be up to 20 alphanumeric characters and cannot include spaces or special characters, such as: + * / , ? () “ ”. Examples are CommandCoil, Fixed_Value, and Setpoint.

Select the register type from the Select Register Type drop-down list. The Modbus Register Types shown are determined by the function codes selected previously. The four types of register groups that support some of the Modbus function codes are R0, R1, R3, R4. The table describes the types, registers, supported codes, and uses. You need the device's Modbus RTU protocol specification for the correct codes to add or delete.

<table>
<thead>
<tr>
<th>Type code</th>
<th>Type of register</th>
<th>Supported function codes</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>R0</td>
<td>Coils</td>
<td>01</td>
<td>Reading coil status</td>
</tr>
<tr>
<td>R0</td>
<td>Coils</td>
<td>05</td>
<td>Setting/forcing/executing coils</td>
</tr>
<tr>
<td>R0</td>
<td>Coils</td>
<td>15</td>
<td>Setting/forcing/multiple coils</td>
</tr>
<tr>
<td>R1</td>
<td>Contacts or discrete inputs</td>
<td>02</td>
<td>Reading contact/discrete inputs</td>
</tr>
</tbody>
</table>
7. Click the **Ok** button to save the new register group. The Register Group window displays in which you finish defining the new register group.

**Figure 18: Define memory map entry**

<table>
<thead>
<tr>
<th>Type code</th>
<th>Type of register</th>
<th>Supported function codes</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>R3</td>
<td>Actual value or input register</td>
<td>04</td>
<td>Reading actual value or input registers</td>
</tr>
<tr>
<td>R4</td>
<td>Setpoint or holding register</td>
<td>03</td>
<td>Reading setpoint or holding registers</td>
</tr>
<tr>
<td>R4</td>
<td>Setpoint or holding register</td>
<td>06</td>
<td>Presetting single setpoint register</td>
</tr>
<tr>
<td>R4</td>
<td>Setpoint or holding register</td>
<td>16</td>
<td>Presetting multiple registers</td>
</tr>
</tbody>
</table>

**Address Format** — See the device user manual to determine if hexadecimal or decimal is appropriate.

**Group Start Address/Group End Address** — EnerVista Integrator supports Modbus RTU extended addressing. In hexadecimal mode, the address range is 0 to FFFF. In decimal mode, the range is 0 to 65535.

Polling speed is based on the scan interval for the topic.

**Fast Poll** — Attempts to scan at the assigned scan Interval. This is the default.

**Slow Poll** — Read register group every three scan intervals. This is typically used for setpoints or low-priority parameters that change infrequently. Slow Poll is a multiple of Fast Poll, with a default value of three. This multiple is controlled in **File > Preferences**.

**Poll Once** — Scan register group only the first time that data is requested by a client application. All future requests for the same data receive the data from this poll. If the device is later declared to be dead, the device is scanned periodically until it comes back online, at which time the Poll Once data is re-read. This is useful for registers with settings of a more permanent nature, which need to be read but are unlikely to change.
Invalid Registers — An invalid register block is a list of registers within a register group that are not polled for data by EnerVista Integrator, perhaps because they are unused by the device itself or simply because they are not required. A register block consists of a contiguous piece of a device’s memory that contains many points of data. Within this block, some addresses can be unused by the device. You can make EnerVista Integrator aware of unused or extraneous addresses by specifying them as invalid register blocks.

Invalid register blocks allow EnerVista Integrator to focus its attention on registers of interest. By not asking EnerVista Integrator to poll addresses that contain no data of interest, you improve server performance. Also, some devices, if asked for a valid register block that happens to contain invalid registers, return a message that the entire block is invalid. Thus, it can be vital to identify any invalid blocks to EnerVista Integrator.

Click the Add, Modify, or Delete button to manage the list.

**Figure 19: Invalid Registers window**

---

**Add GE Fanuc PLC device**

The GE Fanuc PLC 90/70, PLC 90/30, and Micro90 PLC consist of a backplane to which a variety of modules with a range of functions can be attached, from metering and data collection to process control. Because these devices are so flexible and there is no way to predict the options chosen by the end user, they must be configured the same way as a generic device. Follow the instructions in the previous section.

**Delete function codes**

You cannot delete function codes if any user-configured register group exists for the device type. To delete already added function codes, first delete all the register groups calling those functions.
Change a register group name

When adding a register map for a generic device, you gave it a name, which can be changed.

To change a register map name:

1. In the main EnerVista Integrator window, click the Device Type Info button. The Device Types window opens.
2. Select the register type from the list and click the Register Map button. The Register Map window opens.

![Figure 20: Change memory map name for a generic device]

3. Click the Change Register Name button. The Change Register Group Name window opens.
4. Enter the new name and click the Ok button to save and exit.

Export a register group

The memory maps can be exported.

To export a register map:

1. In the main EnerVista Integrator window, click the Device Type Info option. The Device Types window opens.
2. Select the register type from the list and click the Register Map button. The window opens.
3. Click the Export Register Group button. At the prompt, accept or enter a file name for the CSV file.
Use mnemonics

Mnemonics are a way to name registers or groups of registers by assigning a user-friendly name to a register address. For example, it is easier to remember Trip_Set_Points than R41234A5. Mnemonics are useful to speed selection of registers. They are also useful, for the same reasons, when using third-party devices that access the software. For supported GE devices, user-friendly mnemonics are already used.

In addition to regular mnemonics, virtual mnemonics allow calculations and other operations to be performed (next section).

There are two ways to add mnemonic names: manually or import. For imports, CSV files are used.

To use mnemonics:

1. In the main EnerVista Integrator window, click the Device Type Info option. The Device Types window opens.
2. Select the register type from the list and click the Mnemonics button. The Mnemonics window opens. Use it to add, import, update, export, or delete mnemonics. The mnemonic name can have up to 20 alphanumeric characters, but no spaces or special characters, such as + * / , ? ! " '

The next section explains use of the Virtual Mnemonic function.

Figure 21: Mnemonics window

Virtual mnemonics

A virtual mnemonic provides the capability to scale values read from a device or to compute simple values from primary values. For example, it allows calculations to be performed, such as adding Voltage A to Voltage B.

The Virtual Mnemonic Editor is used to add/update/delete Virtual Mnemonics for a device type. The maximum number of Virtual Mnemonics that can be configured is 50 per device type.

The figure shows a virtual mnemonic named “VIRTUAL1” being added to perform a “CONFIG+50” operation.
To add a virtual mnemonic:

1. In the main EnerVista Integrator window, click the Device Type Info option. The Device Types window opens.
2. Select the register type from the list and click the Mnemonics button. The Mnemonics window opens.
3. Click the Virtual Mnemonic button. The window opens.
4. Click the Add button. An entry is created.
5. Enter a Virtual Mnemonic Name, select a Data Type and Mnemonic List, click the Insert button, then enter the operator or constant to the Expression Builder field in the lower window by typing it.

The Mnemonic List allows selection of an existing Mnemonic (non-virtual mnemonic) that can be used in configuring a Virtual Mnemonic expression. When you select a Mnemonic from this list and click the Insert button, this item is inserted in the Expression Builder field at the current cursor position. There needs to be at least one Mnemonic in the expression.

Type or paste the operator into the Expression Builder box. The previous figure shows +50 being added. To use an existing mnemonic, type in the mnemonic name or select the mnemonic from the Mnemonic List and click the Insert button. The figure shows CONFIG added this way. Other examples are

- VM_AMPS = AMPS_A * 0.1
- VM_POWER = AMPS_A * VOLTS_A

Common parenthesis "( )" can be used to define operator precedence and to provide clarity. No other types of brackets are allowed. Examples are

- Expression AMPS_A*(0.01) is valid
- Expression AMPS_A*[0.01] is not valid
The constant value in an expression is always in decimal format; other formats, such as Hex, Octal, and Exponential, are not supported. Examples are:

AMPS_A*ABC is not valid even though “ABC” is a valid number in hex format.
AMPS_A *0.01 and AMPS_A *1000 are valid.

The tables outline supported operations.

Table 7: Valid operations (A and B are existing mnemonics)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
<th>Symbol</th>
<th>Example</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic</td>
<td>Multiplication</td>
<td>*</td>
<td>A<em>B</em>100</td>
<td>Between registers, between register and constant</td>
</tr>
<tr>
<td>Division</td>
<td>/</td>
<td>A/B/100</td>
<td>Between registers, between register and constant</td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>+</td>
<td>A+B+100</td>
<td>Between registers, between register and constant</td>
<td></td>
</tr>
<tr>
<td>Subtract</td>
<td>-</td>
<td>A-B-100</td>
<td>Between registers, between register and constant</td>
<td></td>
</tr>
<tr>
<td>Bit</td>
<td>AND &amp;</td>
<td>A&amp;B, A&amp;100</td>
<td>Between registers, between register and constant</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OR</td>
<td></td>
<td></td>
<td>Between registers, between register and constant</td>
</tr>
<tr>
<td></td>
<td>XOR ^</td>
<td></td>
<td></td>
<td>Between registers, between register and constant</td>
</tr>
<tr>
<td></td>
<td>Complement ~</td>
<td></td>
<td></td>
<td>Only register</td>
</tr>
<tr>
<td></td>
<td>Right shift &lt;&lt;</td>
<td></td>
<td></td>
<td>Between register and constant</td>
</tr>
<tr>
<td></td>
<td>Left shift &gt;&gt;</td>
<td></td>
<td></td>
<td>Between register and constant</td>
</tr>
<tr>
<td>Parenthesis</td>
<td>Right bracket</td>
<td>)</td>
<td>(A+B)*100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Left bracket</td>
<td>(</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 8: Bit operations (A and B are existing mnemonics)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAND ~(A &amp; B)</td>
<td>~(A &amp; 100)</td>
<td>Between registers, between register and constant</td>
</tr>
<tr>
<td>NOR ~</td>
<td>A</td>
<td>~</td>
</tr>
<tr>
<td>XNOR ~</td>
<td>A</td>
<td>^B</td>
</tr>
</tbody>
</table>

6. Click the **Validate and Save** button. Error messages are outlined in the next section.
7. Add any other entries.
8. Click the **Close** button when done.

**Virtual mnemonic error messages**

The table outlines messages.

**Table 9: Virtual mnemonic error messages**

<table>
<thead>
<tr>
<th>Message</th>
<th>Possible causes</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error: Mnemonic (&lt;mnemonic name&gt;= not found in supported mnemonics list</td>
<td>Specified mnemonic is not available for this device.</td>
<td>Check the name, for example if the mnemonic is listed in available Mnemonic List box</td>
</tr>
<tr>
<td>Message</td>
<td>Possible causes</td>
<td>Solution</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Error: Constant &lt;constant&gt; in the expression is out of range(9999999.999999 to 9999999.999999)</td>
<td>The constant used is out of supported range</td>
<td>Configure the constant as per the allowed ranges</td>
</tr>
<tr>
<td>Error: No Mnemonics found in Expression. Please configure at least one mnemonic in expression.</td>
<td>The configured virtual mnemonic does not contain any regular mnemonic. At least one mnemonic is needed for Virtual Mnemonic configuration. Example: 100 + 200</td>
<td>Configure the virtual mnemonic expression using a mnemonic, for example from the Mnemonic List box</td>
</tr>
<tr>
<td>Error: Mnemonics count exceeds 6</td>
<td>More than six mnemonics are configured in virtual mnemonic expression</td>
<td>Maximum six mnemonics are allowed in Virtual Mnemonic configuration. Remove any extra mnemonics.</td>
</tr>
<tr>
<td>Error: Constant count exceeds 6</td>
<td>More than six constants are configured in virtual mnemonic expression</td>
<td>Maximum six constants are allowed in Virtual Mnemonic configuration. Remove any extra.</td>
</tr>
<tr>
<td>Syntax Error: No Operators selected in Virtual Mnemonic Expression</td>
<td>More than one mnemonic is used without specifying an operator between them. Example: AL_MSG_01 HAR_AB_11</td>
<td>Check the virtual mnemonic expression for missing operators and add them, such as + or *</td>
</tr>
<tr>
<td>You have reached the maximum limit for Virtual Mnemonics. Only 50 Virtual Mnemonics per device can be added.</td>
<td>The maximum number of virtual mnemonics supported is reached</td>
<td>There can be 50 virtual mnemonics configured for each device type; reduce the number</td>
</tr>
<tr>
<td>Error: &lt;operator&gt; invalid/unsupported operator found in mnemonic &lt;Mnemonic&gt;</td>
<td>The specified operator is not supported in Virtual Mnemonic configuration</td>
<td>See Valid operations (A and B are existing mnemonics) table</td>
</tr>
<tr>
<td>Syntax error: Expression cannot start with operator &lt;Operator&gt;</td>
<td>Configured Virtual Mnemonic expression starts with an operator. Expression can begin only with these operators (~, !).</td>
<td>Check the expression. Operators are allowed between mnemonics and constants.</td>
</tr>
<tr>
<td>Operator &lt;operator&gt; cannot be applied to operands of type '&lt;Type1&gt;' and '&lt;Type2&gt;'</td>
<td>The operator configured cannot be used with the configured operands. Example: AL_MSG_01 + HAR_AB_11 where AL_MSG_01 is of Boolean type and HAR_AB_11 is of integer. We get error as operator '+' cannot be applied to operands of type 'Boolean' and 'Integer.' To know the type of mnemonic, check the mnemonic format. Example: AL_MSG_01 has format R3x0000D1-2 where D specifies Boolean type.</td>
<td>See Valid operations (A and B are existing mnemonics) table</td>
</tr>
<tr>
<td>Syntax error: Missing closing parenthesis ')'</td>
<td>There is a mismatch between the number of open and closed parenthesis. Example: (Amps_A*.01)</td>
<td>Check the virtual mnemonic expression for number and placement of brackets used</td>
</tr>
<tr>
<td>Syntax error: Missing Opening parenthesis '('</td>
<td>There is a mismatch between the number of open and closed parenthesis. Example: (Amps_A*.01))</td>
<td>Check the virtual mnemonic expression for number and placement of brackets used</td>
</tr>
<tr>
<td>Syntax error: Please re-verify Virtual Mnemonic expression</td>
<td>Possible incorrect usage of operators. Misplaced parenthesis. Example: [(BAUDRATE)+(DELAY_ON_RELAY_1)]</td>
<td>Check the virtual mnemonic expression for operator usage syntax</td>
</tr>
<tr>
<td>Message</td>
<td>Possible causes</td>
<td>Solution</td>
</tr>
<tr>
<td>------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Syntax error: Possibly missing operator between two</td>
<td>Virtual mnemonic expression contains two mnemonics without an operator between</td>
<td>Check the virtual mnemonic expression syntax</td>
</tr>
<tr>
<td>mnemonics/constants or end of expression expected</td>
<td>them. The expression is expecting a mnemonic to be followed by an operator.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Example: BAUDRATE+DELAY_ON_RELAY_1 +</td>
<td></td>
</tr>
<tr>
<td>Unable to validate expression. COM Error.</td>
<td>Serious issue, possible missing/corruption of DLL required. Possible issues</td>
<td>Contact GE technical support</td>
</tr>
<tr>
<td></td>
<td>with EnerVista Integrator installation.</td>
<td></td>
</tr>
</tbody>
</table>
EnerVista Integrator

Chapter 4: Alarms and events

This chapter outlines how to view and manage alarms and event records, as follows:

• Start and stop event logging
• View alarms and events
• Toggle automatic updating
• Filter alarms and events
• Set default view
• Set record number and refresh rate
• Change event type
• Acknowledge alarm
• Create search criteria
• Configure logical expressions
• View events in rolling logs

Introduction

The event logger has the following two components:

• **EventServer** — Polls devices, collects events, and stores them in the Microsoft SQL database. It is activated for a device when its Events check box is enabled during device setup in EnerVista Integrator. By default it is not activated.
• **EventViewer** — The interface to view events

Use the feature to collect, display, and organize event and alarm information from devices in the EnerVista Integrator system. When set as such, the event logger displays a near real-time list of events and alarms and automatically writes the information to the database.

Benefits include:

• Faster corrective maintenance — Pinpoint causes of problems using time-stamped alarms and sequence-of-event records
• Less downtime — Identify and correct a problem before it leads to loss of power and/or damage
• Improved power quality — Identify sources of “dirty” power and take corrective action to prevent damage
• Increased safety — Centralized source of information, reducing need for physical contact with equipment and substation presence

Entellisys and 8 Series devices do not support Events and Waveform retrieval using a serial interface.

# Start and stop event logging

Logging of alarms and events can be turned on and off.

## Start event logging

To start event logging:

1. Access the EnerVista System Status window by double-clicking the icon on the Windows taskbar. If the icon is not displayed, click the up arrow on the taskbar, select Customize, and set the EnerVista System Status to show the icon and notifications. If that is not possible, launch the window by clicking the EISystemStatus.exe file, for example at C:\Program Files (x86)\Enervista\EnerVista Integrator\EISystemStatus.exe

![Status window accessible from Windows taskbar](image)

   **Application** | **Status** | **State** | **Action**
   --- | --- | --- | ---
   Configurator | Running | Close | Close
   Communication Server | Running | Close | Close
   Waveform Server | Running | Close | Close
   Event Server | Running | Close | Close
   Time Download Server | Running | Close | Close

2. If the Event Server state reads Closed, then click its **Start** button. If that does not work, try running EnerVista EventServer service from Control Panel > Administrative Tools > Services, or use the command “net start EventServer” from the Command prompt launched in Administrator mode.

   If that does not work, try closing any open configuration windows and try again.

   When the event server is started, the software stores events in the database.

## Stop event logging

For configuration, stop logging.

To stop event logging:

1. In the EnerVista System Status window, click the **Close** button for the Event Server. The software stops storing events in the database. Note that it can be restarted automatically by the software even though you stopped the server. To ensure that the Event Server and any other servers do not start automatically, stop the EnerVista Watchdog Server in Control Panel > Administrative Tools > Services, or run the command “net stop WatchDogServer” from the Command prompt launched in
View alarms and events

An alarm is the highest priority event and indicates a condition in the network, such as a circuit breaker tripped, a circuit breaker in pickup, or a set-point threshold crossed. An event is lower-priority information that usually indicates a status change, such as notification that the requested waveform capture has occurred, or an internal communication error with a device has been detected.

Any alarm or event can be reassigned as an Alarm or Event.

Both device-generated events and EnerVista Integrator system events can be displayed. The device-generated events display by default upon launch of the Event Viewer. System events, as outlined later, can be displayed separately or with the device events.

To set up alarms for a device, do so in the product's software.

To view device-generated alarms and events:

1. On the main screen in EnerVista Integrator, click the Events option, or click the Start button in the status window. If that does not work, try running the EIEventViewer.exe file, for example at C:\Program Files (x86)\Enervista\EnerVista Integrator\EIEventViewer.exe

   When already in the viewer and there is no open window, click File > New.

   The Event/Alarm Viewer window opens. The window can be blank when devices are not online and/or when there are no records to display.

   Figure 24: View device alarms and events

   The information for each event is as follows:

   Created Time — Time that the event occurred

   Event Type — If the new event was recorded due to the operation of an element or feature within the relay, it is classified as an Event. If the new event was recorded due to a possible problem with any of the devices in the system, such as the detection of a faulty connection, it is classified as an Alarm.

   Source Name — Name of the device that recorded the event

   Display Name — Blank

   Source Type — Type of device that recorded the event, such as UR version 5.50 or 369

   Event — Description, such as power-on event or power-off event

   Event Code —

   Acknowledge — The severity of the alarm and whether or not it was manually acknowledged by a user
2. By default the display is updated automatically. Either click the Don’t Refresh icon on the toolbar or use the refresh options outlined later to change the preference.

You can open additional child windows, but there must always be at least one window open for correct data transfer to the database.

Event viewer can display the entries with different search criteria pre-built as commands, as follows:

- Device Events — Specific device-related events
- Waveform Events — All waveform server related events
- Alarms — All alarms
- Unacknowledged Alarms — Only unacknowledged alarms
- System Events — EnerVista Integrator system-related log events
- Annunciator Events — All events configured in EventServer for the front annunciator panel of the device

You can create search criteria as well. The following sections outline filtering and searching.

---

**Toggle automatic updating**

Automatic updating of event records can be turned on and off. The default, as outlined later, can be set.

To turn automatic updating on and off:

1. In the event viewer window, click the Refresh or Don’t Refresh icon on the toolbar. When the software updates the records automatically, the Don’t Refresh icon is active. When the software does not update the records automatically, the Refresh icon is active.

![Figure 25: Refresh (left) and Don’t Refresh (right) icons on toolbar](image)

After a refresh takes place, a “Refresh is Over” message displays in the status bar at the bottom of the window.

---

**Filter alarms and events**

The table outlines the toolbar icons to sort the Event/Alarm Viewer display. Similar options are accessible from the View menu.

You can also create search criteria and logical expressions to filter data; see those sections. To filter for a specific device, create search criteria.

To filter events:

1. Click an icon on the toolbar. A new window launches and displays any available events.
Set default view

Upon installation, the device-generated events display. This default can be changed, and as such operates as an additional filter. There are several options, including colors, formats of date and time, ascending or descending order, types of events, and columns to display.

To set default events viewed:

1. In the event viewer window, click **File > Configure**. The window opens.
2. Select the events to display upon launch of the Event Viewer. The default is Sequence of Events.
of Events, which displays alarms and events.

Figure 27: Default filtering of events

3. Click the Ok button to save and exit.

To change default colors:
1. In the event viewer window, click Settings > Display Options > Colors. The window opens.
2. Click a button, such as Alarms Warning - Acknowledgeable and select a new color in the window that opens. Click the OK button to save and exit.
3. Click the Ok button to save and exit. The color of any applicable record changes in the viewer.
To set date and time formats and event order:

1. In the event viewer window, click **Settings > Display Options > Time**. The window opens.

2. Select a **Date** format from the drop-down list. The options are
   - MM YY
   - MM YYYY
   - YYYY MM DD
   Select a **Time** format from the drop-down list. The options are
   - HH MM
   - HH MM SS
   - HH MM SS MSEC
   To enable/disable either function, use its check box.
   To display the most recent record first, select the **Descending** option from the drop-down list. To display the oldest record first, select the **Ascending** option from the drop-down list.

3. Click the **Ok** button to save and exit. The event records update accordingly.
To set event types and columns to display:

1. In the event viewer window, click Settings > Display Options > Events. The option is also selectable from the tool bar. The window opens.

2. To set which event types to display, enable/disable them in the upper part of the window. Notes for some of the options are as follows.

   **Fault Reports** — These faults are events such as line faults or ground faults recorded by certain fault-sensitive devices. These devices are the LPS, ALPS, DFP100, DFP200, and SM-3.

   **System Events** — To include EnerVista Integrator events with the device events in the same window.

   **Annunciator Events** — Related to front panels of devices.

   To set which columns display, enable/disable them in the lower part of the window.

3. Click the Ok button to save and exit. The event records update accordingly.

**Figure 29: Setting event order and timestamps**

**Figure 30: Changing the event view display**
Set record number and refresh rate

The default is that automatic refresh is not done, and otherwise 200 event records display at a three-second refresh rate.

**Figure 31: Setting number of records to display and refresh**

![Image of refresh parameters window]

To set number of records and refresh rate:
1. In the event viewer window, click **Settings > Refresh Options**. The window opens.
2. Set the parameters
   - **Refresh** — To have the event records updated automatically, select the Yes option.
   - **View Size** — Set the number of records to display, between 200 and 2,000.
   - **Refresh Interval** — The minimum is three seconds. The Refresh field must be set to Yes for record updates to take place.
3. Click the **Ok** button to save and exit. Any fields outside the allowed ranges are flagged. The event records update accordingly.

Change event type

An event can be reclassified as an alarm, and an alarm can be reclassified as an event.

To change an event type:
1. In the event viewer window, select the event/alarm. Or right-click it.
2. Click **Edit > ChangeEventType** and select an option.

Acknowledge alarm

Alarms can be acknowledged in EnerVista Integrator, on the device front panel, or the device software.

To acknowledge an alarm in EnerVista Integrator:
1. In the event viewer window, select the alarm.
2. Right-click the alarm and select **Acknowledged**. The status in the **Acknowledged** column changes from Unacknowledged to Acknowledged.
Create search criteria

Create search criteria to filter alarms and events. This feature allows you to add, edit, delete, and execute a query of the database, such as filtering for a specific device.

To create a search filter:

1. In the Event/Alarm Viewer window, click **View > SQL Queries**, or when queries already have been configured, the icon can be clicked on the toolbar. The window opens.

2. To add a query, enter a name in the **New Query** field, click the **Add** button, select it, then click the **Configure** button. The window opens.
3. Select the search criteria from the drop-down lists. In the example shown, filtering is done to display the events for two devices, K.UR and G79. Click the **Ok** button to exit.

4. Click the **Execute** button to search events and display the results.
   The configured queries are saved and can be invoked manually from the tool bar.

---

**View events in rolling logs**

In addition to the Event Viewer, log files can be viewed. These logs are useful, for example, to view which devices are non-responsive, labelled as dead.

To access rolling log files:

1. In Windows, navigate to `C:\Users\Public\Documents\EnerVista\EnerVista Integrator\Logs` or to the Log files path if the path has been redefined in the configuration. There are logs for previous days, as well as current logs. The current log is `EnerVistaRollLog.txt`.

2. Click a file to open it. If prompted, use any text editor to open the file.
Figure 34: Rolling logs
EnerVista Integrator

Chapter 5: Waveforms

This chapter outlines the following:
- Start waveform server
- Enable waveform retrieval
- View COMTRADE file
- View phasors
- View harmonics
- Merge COMTRADE files
- Resample COMTRADE file
- Toolbar and buttons

Introduction

A waveform is a graphical display of data, such as voltage or current over time and usually from a triggered event. When supported by a device in the system, waveforms can be displayed in EnerVista Integrator. Entellisys and 8 Series devices do not support Events and Waveform retrieval using a serial interface.

The viewer within EnerVista Integrator provides a visual display of power systems data and relay operation data captured during a specific triggered event. The triggering of waveforms is determined by the settings made in the device. There are no default device settings for capturing waveforms; each device must be configured with the triggers.


The viewer can display oscillography, phasors, harmonics, and actual values retrieved from a COMTRADE file. They can be saved as CSV files. CSV files retrieved from GE products can be combined with existing COMTRADE files and viewed within a single window.

This chapter focuses only on viewing retrieved waveforms. When there are no waveforms retrieved, you need to configure the device to generate one or open an existing file.
Start waveform server

The EnerVista Integrator waveform server needs to be running. Use the system status window to verify or start operation. See the Display server status section on page 20 if required.

Figure 35: Status window accessible from Windows taskbar

To start the waveform server:
1. Ensure that the Waveform Server is running; click its Start button if required.

Enable waveform retrieval

Waveforms are available from devices that support and are configured in EnerVista Integrator for automatic waveform retrieval. By default, automatic waveform retrieval is not activated during device setup in EnerVista Integrator.

To enable waveform retrieval for a device in EnerVista Integrator:
1. In the main window of EnerVista Integrator, click the Device Setup option.
2. Select the device to view its panel.
3. Enable the Waveforms check box. If the box is unchecked or the option is grayed out, the system does not retrieve the waveform for the device.
4. Click the Ok button to save and exit.

Figure 36: Waveform retrieval enabled in Device Setup window

Once activated, EnerVista Integrator polls the device continuously for any new waveforms. Once a new waveform is detected, it is retrieved. An event is also generated for the event viewer. To check for new waveforms, look at the event viewer or the waveform viewer.
View COMTRADE waveforms

To view waveforms from COMTRADE files:

1. In the main window of EnerVista Integrator, click the Waveforms option, then the View option in the window that opens. If in the Waveform Viewer window already, click File > Open or select the icon on the toolbar. A selection window opens.

Figure 37: Waveforms option

2. Select the .cfg waveform to be viewed; all retrieved waveforms from all devices are listed for selection. The file name includes both the device name and the timestamp of when the file was generated in the device. If there are no .cfg files displayed and you have other EnerVista software installed, try navigating to C:\Program Files (x86)\GE Power Management\URPC\Data\Demo to view a demonstration file.

Once a waveform file is selected, the viewer launches. The following table outlines some options available in the window.
The top left of the window shows the trigger date and time. The yellow Delta box at the top right indicates the difference between the two cursors.

**Table 11: Some waveform window options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red line</td>
<td>The trigger position (%) of the data capture</td>
</tr>
<tr>
<td>Green and blue lines / cursors</td>
<td>Initial and final times. Can be moved either by clicking and dragging them left and right across the duration period of the signal, or by using the Cursor 1, Cursor 2 scrolling bars at the top of the window. The red line is the trigger position and cannot be moved across the captured waveforms. There are three time values indicated in the top right boxes listing the selected time for Cursor 1, Cursor 2, and the Delta value. The delta value is the calculated time difference between Cursor 1 and Cursor 2.</td>
</tr>
<tr>
<td>Playback Rate</td>
<td>The number of samples shown every second. It can be increased/decreased in order to improve the resolution of the playback.</td>
</tr>
<tr>
<td>Blue field. Displays the parameter value at the blue cursor 2 position. When in Start mode, displays the time offset from the start time of the COMTRADE file. When in Trigger mode, displays the amount of time from the trigger position (red line).</td>
<td></td>
</tr>
</tbody>
</table>
CHAPTER 5: WAVEFORMS

ENERVISTA INTEGRATOR – INSTRUCTION MANUAL

Option | Description
---|---
Green field. Displays the parameter value at the green cursor 1 position. When in Start mode, displays the time offset from the start time of the COMTRADE file. When in Trigger mode, displays the amount of time from the trigger position (red line).

Delta yellow field. The relative parameter difference between the two cursor amplitude values. The difference in magnitude. The time is the difference in seconds.

Start button. To display the cursor times as an offset from the “Start Time” of the COMTRADE file. These times are always a positive value.

Trigger button. To display the cursor times as an offset from the “Trigger Time” of the COMTRADE file. A negative time indicates a time that occurs before the trigger and a positive time indicates a time that occurs after the trigger.

Actual button. To display the cursor times as an actual time stamp. The format for the time stamp is “mm/dd/yy HH:mm:ss.ssssss” and hours are based on a 24 hour clock.

Play button. Use it to play Cursor 1 throughout the entire period or sections of the waveform(s). The speed of play is controlled by the Playback Rate, which is by default 1 Sample. The larger the value, the faster the cursor travels across the signal. (Playback rate can be changed on the spot during playback) During playback, the Phasors screen and Harmonic screen are also updated accordingly in real-time based on the position of Cursor 1.

Stop button. Halts play. The playback automatically rewinds and repeats when the end of oscillography record is reached.

Zoom. A section of the waveform can be magnified by right-mouse-clicking and dragging the outline box over the desired segment. Multiple zooms are also possible. When utilizing this function, the Zoom Out button becomes active for zooming out.

Superimpose waveforms. Waveforms can be super-imposed on top of each other by selecting and dragging them with the left mouse button.

Set preferences

Up to 40 channels can be plotted in various colors, line styles, and groups for simultaneous display. These channels can be a combination of analog and digital channels. Phasors can only be set up to the number of analog channels being used. For example, if 20 Analog channels are enabled, then 20 Phasor channels can be used.

To set preferences:

1. With the waveform file open and stopped, click the Preferences button on the toolbar. The window opens. Any changes made are specific to the waveform file open.
2. Complete the General panel. Use this panel to add comments to the COMTRADE file, display channel names, alter the window transparency, and choose a background color. These changes effect the display of the current Oscillography, Phasor, and Harmonics screens.

3. Complete the Analog Channels panel.
   - **Channel** — Displays the name of each channel/waveform. Read-only.
   - **Color** — Click the color to change the displayed color for that channel.
   - **Scaling** — Allows for channels to be grouped so that they share the same scale.
   - **Line Style** — Selects the format of the displayed line for that channel.
   - **Graph** — Enable to display the channel on the waveform graph.
   - **Phasor** — Enable to display the channel on the phasor graph.
   - **FFT** — Enable to display the channel on the harmonic graph.

   Optionally customize the Phasor display of the analog channels with the following options.
   - **Select Reference** — Allows the selection of an analog channel to be used as a zero phase angle reference for the phasor graph. If None is selected, the absolute channel magnitudes and phase angles are plotted according to the position of cursor 1.
   - **Maximum harmonic to calculate** — Default is three.
   - **Samples/Cycle** — For proper display of the phasor angle(s), enter the sampling rate for the data points of the COMTRADE file. Phasors are incorrect if an incorrect value is specified for the samples/cycle.
   - **Channel** — Displays the name of each channel/waveform. Read-only.
   - **Change Detected** — A check mark is generated when a change of state is detected. Read-only.
   - **Color** — The color displayed for that channel on the waveform.
   - **Line Style** — The format of the displayed line for that channel.
   - **Graph** — Enable to display the channel on the waveform graph.

5. Complete the Symmetrical Components panel. This panel allows the symmetrical components to be calculated and shown for a three-phase system.
   - **Channel** — Displays the name of each channel/waveform. Read-only.
   - **Scaling** — Allows for the channels to be grouped so that they share the same scale.
   - **Phase A** — Phase A component to be used.
   - **Phase B** — Phase B component to be used.
   - **Phase C** — Phase C component to be used.
   - **Colors** — The colors displayed for channel phases on the waveform.
   - **Phasor** — Enable to display the channel on the phasor graph.
Figure 43: Symmetrical Components panel

6. Click the Ok button to exit. Changes are for the current session only unless saved.

View phasors

A Phasor diagram indicates the rotation, magnitude, and angle with respect to a selected reference component chosen in the Preferences window.

A Phasor diagram is viewed simultaneously with the oscillography waveforms and can be resized. By either dragging the cursor or clicking the play button, the Phasor diagram updates the position of the cursor based on the playback rate.

Clicking an icon on the toolbar opens the Phasor window.

To open the phasor window:

1. With the waveform/COMTRADE file open, click the Phasor button on the toolbar. The window opens. The actual values for the phasor quantities, such as amplitude and phase angle, display in the Magnitude/Angle column. If the window is blank, set the preferences to display content, as outlined in the previous section.

2. Click the Play button on the main toolbar (not in the Phasor window).

3. In the oscillography window, click and drag the vertical green line left, for example, to change the display.
View harmonics

The Harmonics table lists the calculated percentage of total harmonic distortion (THD) due to each phase. The Preferences window can be used to change which values display and the colors.

The harmonic spectrum is viewed simultaneously with the oscillography waveforms. Clicking an icon on the toolbar opens the window. The window can be resized.

To open the harmonics window:

1. With the waveform/COMTRADE file open, click the Harmonics button on the toolbar. The window opens. If the window is blank, set the preferences to display content, as outlined earlier.

2. Click the Play button on the main toolbar (not in the Harmonics window).
3. In the oscillography window, by either dragging the green line or clicking the Cursor 1 or 2 button, the diagram updates to the corresponding position of the cursor.

The table lists the calculated percentage of THD due to each phase.
Merge COMTRADE files

When a COMTRADE file is in an ASCII Data file format, an oscillography COMTRADE (.cfg) file is readable by spreadsheet applications. Such files can be merged.

To merge CFG files:

1. In the main EnerVista Integrator window, click the **Waveforms** option. Or click **Tools** > **Waveforms** when in the application already. The window opens.
2. Click the **Merge** option. A wizard opens.
3. Complete the fields.
Select 1 or 2 COMTRADE files — Click the ... browse button and select the .cfg files to merge. The first COMTRADE file entered in the list is considered the reference file, which determines the start time and trigger time of the merged file.

Select Destination COMTRADE file — Enter a name and destination of the output file. Use the ... browse button to navigate.

Format of COMTRADE Data file — Select ASCII to save the files in a text format and view them as a spreadsheet. Select Binary to save smaller files that are viewable only in the COMTRADE viewer.

Click the Next button. The wizard advances.

4. Complete the fields.

On the left side are the available waveforms from both source COMTRADE files. On the right are the selected waveforms for the destination COMTRADE file. Highlight a required waveform from the source files and use the single right arrow button to move it to the destination file. Or use the double right arrow button to move all the waveforms from the analog list to the destination file.
To remove any incorrectly selected waveforms from the destination list, use the trash can icon. The up and down buttons are provided for re-ordering the analog list of the destination file.

Click the **Next** button. The wizard advances.

5. Complete the fields, this time for digital channels.

![Figure 49: Digital channels](image)

Click the **Next** button. The wizard advances.

6. Complete the fields.

![Figure 50: Sample rate](image)

At the top of the window are four boxes detailing the start and end times of the two source COMTRADE files. If synchronization is required, the **Trigger in the second file lagging by** field is given to add an offset to the second file. This offset can be negative, in which case the first file lags the second file.

**Destination - Sample Rate** — Enter the resample rate in Hertz. The default value is 3840 Hz. This is the rate for the destination file. You know the original sampling rate from computer software settings, for example 64 samples/cycle for a 64-bit computer.
**CHAPTER 5: WAVEFORMS RESAMPLE COMTRADE FILE**

**Open in Waveform Viewer** — Enable the check box to view the COMTRADE file after merging. Disable to merge the file and not view it, or if you are generating ASCII files.

7. Click the **Ok** button. The two source COMTRADE files are merged into the specified destination file.

If three or more files are to be merged, this process can be repeated using the destination file from the first merge as one of the source files for a second merge.

---

**Resample COMTRADE file**

Sampling refers to the data collected. Sampling rate is the frequency at which the data is collected. For COMTRADE files, the sampling rate is specified in Hertz (Hz). Resampling takes a subset of the data collected.

Resampling a COMTRADE file allows you to convert a COMTRADE file with a variable sampling rate to a COMTRADE file with a fixed sampling rate. Additionally, a fixed sampling rate of a COMTRADE file can be changed to a new value.

To resample a COMTRADE file:

1. In the main EnerVista Integrator window, click the **Waveforms** option. Or click **Tools > Waveforms** if already in the application. The selection window opens.
2. Click the **Resample** option. The window opens.
3. Complete the fields.

**Figure 51: Changing the sampling rate**

**Select Source COMTRADE file** — Click the ... browse button and select the .cfg file to resample.

**Select Destination COMTRADE file** — Enter a name and destination of the output file. Use the ... browse button to navigate, for example to select the existing file and change its name, for example to "_new."

**Format of COMTRADE Data file** — Select **ASCII** to save the files in a text format and view them as a spreadsheet. Select **Binary** to save smaller files that are viewable only in the COMTRADE viewer.

**Destination - Sample Rate** — Enter the resample rate in Hertz. The default value is 3840 Hz.

**Open in Waveform Viewer** — Enable the check box to view the COMTRADE file after it is created. Disable to resample the file and not view it.
4. Click the Resample button in the window to resample and exit. When the option to open the file is selected, the viewer launches. A .cfg file, a .dat data file, and a .hdr header file are generated.

**Toolbar and buttons**

This section explains the waveform viewer and the phasor window.

**Toolbar**

- **Open**: Opens/loads an existing COMTRADE file (.CFG)
- **Save As**: Saves current .CFG file with existing file name. If a file name has not been specified, the software prompts you to name it.
- **Print**: Prints the waveform
- **Preferences**: Opens the waveform preferences window
- **Data**: Shows the actual value of the waveform at the specified cursor position
- **Phasor**: Shows the phasor diagram of the waveform at the specified cursor position
- **Harmonics**: Shows the harmonic spectrum of the waveform at the specified cursor position
- **Play**: Begins moving the first cursor through waveform samples at the specified sampling rate. During playback, the Phasors screen and Harmonic screen also are updated accordingly in real time based on the position of cursor 1. The playback automatically rewinds and repeats when the end of oscillography record is reached.
- **Stop**: Stops moving the first cursor through the waveform; stops the waveform
- **Zoom out**: Zooms out from the previously selected scale. A section of waveform(s) can be zoomed in by right-mouse clicking and dragging the outline box over an area. Multiple zooms are possible. Waveforms can be super-imposed on top of each other by selecting and dragging them with the left mouse button.
Waveform functions

**Vertical Red Line**
- Indicates the trigger position (%) of the data capture.

**Blue and Green Vertical Lines/Cursors**
- Indicate initial time and final time. Can be moved either by clicking and dragging them left and right across the duration period of the signal, or by using the Cursor 1, Cursor 2 scrolling bars at the top of the window. The red line is the Trigger position and cannot be moved across the captured waveforms.

**Playback Rate**
- The number of samples shown every second; the speed of Cursor 1 during playback. Can be increased/decreased in order to improve the resolution of the playback. The default is 1 sample. The larger the value, the faster the cursor travels across the signal.

**Green**
- Displays the parameter value at the green Cursor 1 position.
  - When in Start mode, displays the time offset from the start time of the COMTRADE file.
  - When in Trigger mode, displays the amount of time from the trigger position (red line).

**Blue**
- Displays the parameter value at the blue Cursor 2 position.
  - When in Start mode, displays the time offset from the start time of the COMTRADE file.
  - When in Trigger mode, displays the amount of time from the trigger position (red line).

**Yellow**
- Displays the difference between the green and blue parameter values. The box shows the difference in time (seconds).

**Start**
- Displays cursor times as an offset from the “Start Time” of the COMTRADE file. These times are always a positive value.

**Trigger**
- Displays cursor times as an offset from the “Trigger Time” of the COMTRADE file. A negative time indicates a time that occurs before the trigger and a positive time indicates a time that occurs after the trigger.

**Actual**
- Displays cursor times as an actual time stamp. The format for the time stamp is “mm/dd/yy HH:mm:ss.ssssss” and the hours are based on a 24 hour clock.

**Phasor Window**

Use the Preferences window under **File > Preferences** to change the values displayed, the number of phasors, and the colors.
Phasor magnitude view attributes are set by highlighting the following options.

- **Peak** versus **RMS** — Select between peak and root mean square (RMS) phasor magnitudes.
- **Primary** versus **Secondary** — Select between the primary and secondary phase voltages.
- **Scaled** versus **Fixed** — Select between scaled phasors and fixed magnitude phasors. Fixed magnitude phasors ignore the magnitude value and only show the angles.
EnerVista Integrator

Chapter 6: Maintenance

This chapter outlines maintenance of the software.

- Troubleshoot using Traffic Logger
- Back up files
- Restore files
- View software version
- View and manage software license
- Update software
- Manage activation code
- Transfer software license
- Uninstall software

Troubleshoot using Traffic Logger

Logs can be viewed for devices in order to troubleshoot. The interface is the I/O Traffic Logger.

To use the Traffic Logger:

1. In Windows, navigate to the EIIOTrafficEnabler.exe file, for example in C:\Program Files (x86)\Enervista\EnerVista Integrator\EIIOTrafficEnabler.exe
2. Double-click the file to launch the software.
3. Click the I/O Traffic icon on the toolbar. The window opens.
4. Enable the feature to view, then click the Close button to view the information.
Back up files

Configuration can be backed up. This includes device setup, system parameters, and preferences. The device settings can be edited, then imported.

When upgrading the software, preferences and device setup are retained without backing up files, though good practice is to back up files regardless.

To back up files:

1. Click **File > Export Configuration**. The window opens.
2. Enter a name and location for the files, then click the **Save** button. The files are saved in the .zip format. Keep the .zip format. The contents is as follows:
   - **DeviceProfiles** — Data, registers, Modbus memory map for all devices supported, for example when accessing **Device Type Info** functions
   - **DeviceConfigurationDefinition** — List of devices
   - **DeviceType** — List of all devices supported by the software that appear in the **DeviceType** drop-down list.
   - **EnervistaOPCServerConfig** — Settings for **File > Preferences** and additional background server settings
   - **SystemConfigurationDefinition** — Settings for log files and events database
   - **Topic.csv** — Device settings as entered in **Device Setup**
To edit device setup:

1. Unzip the backed up folder.
2. Make a copy of the Topic.csv file, for example naming it Topic_backup.csv.
3. Access the Topic.csv file. It displays the serial (GE32MODBSETTINGS) and Ethernet (GE32MTCPSSETTINGS) device setups. The file needs to have both sections, even when no devices are entered for them.

For serial:
Port,<<PortName>>,<<IPAddr:Port>>
where Parity is n=none, e=even, o=odd
Device,<<DeviceName>>,<<DeviceType>>,<<PortName>>,<<SlaveID>>,<<PollingPeriod>>,<<Enable>>,<<WaveformEnabled>>,<<EventsEnabled>>,<<PMUEnabled>>,<<MultinetEnabled>>
where 1=enabled and 0=disabled

For Ethernet:
Port,<<PortName>>,<<PortName:BaudRate>>,<<Parity>>,<<DataBits>>,<<StopBits>>
where Parity is n=none, e=even, o=odd
Device,<<DeviceName>>,<<DeviceType>>,<<PortName>>,<<SlaveID>>,<<PollingPeriod>>,<<Enable>>,<<WaveformEnabled>>,<<EventsEnabled>>,<<PMUEnabled>>,<<MultinetEnabled>>
where 1=enabled and 0=disabled

4. Edit and save the file.
5. Zip the file.
6. Click File > Import Configuration. The modified file is imported into the software.

**Restore files**

Configuration files that have been backed up can be restored.
To restore files:
1. Click **File > Import Configuration**.
2. At the prompt, select the .zip file to restore, then acknowledge completion at the prompt.

### View software version

To view the version number of EnerVista Integrator:
1. Click **Help > About Configurator**. The window opens.
2. View the number in the **Version** field.
3. Click the window to exit.

To view the version number of the Event viewer:
1. In the main window of EnerVista Integrator, click the **Events** option. The window opens.
2. Click the **About** icon on the toolbar or click **Help > About Event/Alarm Viewer**. The window opens.
3. View the number in the **Version** field.
4. Click the **Ok** button to exit.

To view the version number of the Waveform viewer:
1. In the main window of EnerVista Integrator, click the **Waveforms** option. The window opens.
2. Click the **About** icon on the toolbar or click **Help > About Waveform Viewer**. The window opens.
3. View the number in the **Version** field.
4. Click the **Ok** button to exit.

### View and manage software license

After installation, the software license is viewable from the CD and/or from a folder on the computer. The number of licenses purchased can also be viewed.

To view the software license on computer:
1. Navigate to the software folder, for example `C:\Program Files (x86)\Enervista\EnerVista Integrator` or `C:\Program Files\Enervista\EnerVista Integrator` and view the license as the license.txt file.

The number of software licenses purchased is viewable in the software and online over the Internet.

To view in the software the number of software licenses purchased:
1. In the software, click **Help > License Management**. The window opens.
2. View the **License Status** field.
Figure 55: License

To view online the number of software licenses purchased:
1. Log in to
   https://apps-ex.qs.ec.ge.com/swmgr/
   using the Order # and Password provided with the software or sent by email upon purchase.

Update software

The software can be upgraded for new features and fixes. When purchased with the optional upgrade package, the updates are free for one year.

The EnerVista Integrator license also can be upgraded to add more devices and/or data points by entering a new activation code. First do a license transfer as outlined later.

To update the software:
1. Contact GE Grid Solutions for updates to EnerVista Integrator software. The updates are not available on the web site.
2. Download the file to the desktop and double-click the .exe file.
3. Complete the wizard.
4. Restart the computer at the prompt.

Manage activation code

A valid software license is required, which is managed using an activation code. See the Quickstart Guide to add the activation code and unlock the software.

When updating the license, if the application is unlocked and you upgrade to a larger number of devices, first do a license transfer (for example, use the Site ID). This removes the previous license, restarts the program, and you enter the new license code. See the next section.

Transfer software license

A license/activation code allows installation on one computer, and you can move the software license from one installation to another. You cannot move a complete installation with its database to another computer, only the license.
The process is as follows. You install EnerVista Integrator at the new computer, look up its **Site ID**, then transfer the license at the old EnerVista Integrator computer.

Also transfer the license when upgrading to a larger number of devices/data points. This removes the previous license, restarts the program, and you enter the new license code.

**Figure 56: Transfer software license**

To view the Site ID:

1. Using the new installation of EnerVista Integrator, click **Help > License Management**. The window opens.
2. Record the **Site ID**.

To transfer the license:

1. Using the old installation of EnerVista Integrator, click **Help > License Management**. The window opens.
2. Enter the recorded site ID in the **New Site ID** field, then click the **Transfer** button. First, a prompt appears to acknowledge that the installation locks on the computer. Second, a prompt appears that the server needs to close and to disconnect/close any open installations. A New Activation Code window displays.
3. Record the Activation Code for the destination computer, then close the window.
4. Add the recorded Activation Code at the new installation.

With successful transfer, the license on the old installation is disabled, and the license on the new installation is enabled.

Uninstall software

If required, the EnerVista Integrator software can be uninstalled.

Uninstalling the software also deletes configuration information. It does not delete some files, such as error logs, system logs, and configuration records, which are created after the EnerVista Integrator installation completes. Since these files are not part of the initial installation, they are not removed by the uninstaller and must be deleted manually. Any Microsoft SQL Server database remains.

To uninstall the EnerVista Integrator software:
1. With the software closed, click Start > Control Panel.
2. Click Programs and Features.
3. Click EnerVista Integrator. If the items does not display, uninstall it from the .exe installation file.
4. Click Uninstall and confirm the deletion. The EnerVista Integrator software is deleted.

To uninstall the Microsoft .NET Framework and Microsoft SQL Server that was installed/used by EnerVista Integrator, follow a similar approach. Do not uninstall these applications when they are being used by other software on your computer. Search the Internet for ways to determine the applications using .NET and the SQL Server.

For files not uninstalled automatically try the following folders:
C:\Program Files (x86)\Enervista\EnerVista Integrator
C:\ProgramData\Enervista\EnerVista Integrator
This chapter outlines the document revision history.

### Revision history

The tables outline the releases and revision history of this document.

#### Table 12: Revision history

<table>
<thead>
<tr>
<th>GEK publication number</th>
<th>1601 part number</th>
<th>Software</th>
<th>Release date</th>
<th>ECO</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEK-119539</td>
<td>1601-9214-A1</td>
<td>7.00</td>
<td>March 2013</td>
<td>13-</td>
</tr>
<tr>
<td>GEK-119594</td>
<td>1601-9214-B1</td>
<td>7.1x</td>
<td>March 2014</td>
<td>14-</td>
</tr>
<tr>
<td>GEK-119697</td>
<td>1601-9214-C1</td>
<td>7.2x</td>
<td>8 April 2015</td>
<td>15-</td>
</tr>
<tr>
<td>GEK-130903</td>
<td>1601-9214-D1</td>
<td>8.0x</td>
<td>20 May 2016</td>
<td>16-</td>
</tr>
</tbody>
</table>

#### Table 13: Major changes for version D1

<table>
<thead>
<tr>
<th>Page</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>---</td>
<td>General revision, including updated branding from GE Digital Energy to GE Grid Solutions, updated several screen captures</td>
</tr>
<tr>
<td>6</td>
<td>Added License Capacity section</td>
</tr>
<tr>
<td>---</td>
<td>Added and updated Alarms and Events chapter, such as added instructions for setting preferences and performing database queries</td>
</tr>
<tr>
<td>---</td>
<td>Deleted OPC Server and Waveform Server chapters, and updated references to the OPC Server. Functions are now integrated with the software.</td>
</tr>
<tr>
<td>43</td>
<td>Deleted the Configure Logical Expressions section from the end of the Alarms and Events chapter</td>
</tr>
<tr>
<td>61</td>
<td>Added Maintenance chapter</td>
</tr>
</tbody>
</table>
# EnerVista Integrator

## Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud rate</td>
<td>A measurement of a signaling rate or information-carrying capacity of a communication channel. Communicating devices typically have configurable baud rates to provide compatibility with various-speed communication networks. Higher baud rates provide faster data-refresh times.</td>
</tr>
<tr>
<td>Commnet</td>
<td>A POWER LEADER standard for device communications that specifies the communication protocol and the communication network</td>
</tr>
<tr>
<td>Communication protocol</td>
<td>A language or convention used for transmission and reception of binary data. A communication protocol often is independent of the physical method or network used for transmission. Modbus RTU and TCP/IP are examples of communication protocols.</td>
</tr>
<tr>
<td>COMTRADE</td>
<td>Common format for transient data exchange. A file format used for many GE products, such as the Universal Relay (UR) family. For EnerVista Integrator, COMTRADE files are used to display waveforms.</td>
</tr>
<tr>
<td>CSV</td>
<td>Comma separated value. Files can be exported with data arranged by the presence of commas in the file. This is referred to as a CSV file. For EnerVista Integrator, device and register files can be imported and exported as .csv files, and events are stored in this format as well.</td>
</tr>
<tr>
<td>Ethernet</td>
<td>A common communication network used for local-area networks (LANs) of computers. Ethernet-based EnerVista Integrator systems provide high-speed, reliable communications at 10 megabits per second.</td>
</tr>
<tr>
<td>Ethernet Gateway</td>
<td>A POWER LEADER device used to connect four RS485 Modbus RTU networks to an Ethernet TCP/IP network. A gateway increases performance of an EnerVista Integrator system through multiple Modbus networks and reduces overall wiring costs through reuse of existing Ethernet LAN wiring.</td>
</tr>
<tr>
<td>HMI</td>
<td>Human-machine interface. The user interface.</td>
</tr>
<tr>
<td>LAN</td>
<td>Local-area network</td>
</tr>
<tr>
<td>Modbus</td>
<td>A POWER LEADER device used to connect eight commnet networks to an RS485 Modbus RTU network. The Concentrator provides full compatibility among the EnerVista Integrator software and the extensive line of POWER LEADER devices with commnet communications, as well as simple expansion of an RS485 Modbus RTU network up to 247 devices.</td>
</tr>
<tr>
<td>Modbus RTU</td>
<td>An industry-standard, nonproprietary communications protocol typically used in medium-speed networks (up to 115.2 kbps) on RS485. RTU refers to a remote terminal unit.</td>
</tr>
<tr>
<td>MultiNet</td>
<td>An Ethernet communications module that allows connection for up to 32 Modbus devices, providing Modbus TCP/IP communications for these devices over Ethernet. This allows connection to fiberoptic LAN and WAN systems for remote access to data.</td>
</tr>
<tr>
<td>Acronym</td>
<td>Definition</td>
</tr>
<tr>
<td>---------</td>
<td>------------</td>
</tr>
<tr>
<td>OPC</td>
<td>Open platform communication. A standard for sharing data among applications and devices.</td>
</tr>
<tr>
<td>OPC Server</td>
<td>A software application that typically runs in the background, gathering information from the network and providing the information in open platform communication (OPC) format for use by one or more applications. The EnerVista Integrator has such a server, and it runs invisibly in the background.</td>
</tr>
<tr>
<td>PLC</td>
<td>Programmable logic controller. GE Fanuc products are PLCs that can be added to EnerVista integrator.</td>
</tr>
<tr>
<td>POWER LEADER</td>
<td>A family of GE power-management devices, including meters, relays, trip units, and software.</td>
</tr>
<tr>
<td>RS485</td>
<td>An industry-standard communication network supporting up to 32 networked devices. RS485 provides medium-speed, reliable communication transport through shielding, balanced transmission voltages, and termination.</td>
</tr>
<tr>
<td>RTU</td>
<td>Remote terminal unit.</td>
</tr>
<tr>
<td>SCADA</td>
<td>Supervisory control and data acquisition. A category of systems that acquire data for logging and analysis, as well as providing supervisory control in applications without time-critical requirements. Power-management systems are a direct application of SCADA technology.</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>Transmission control protocol / Internet protocol. A standard protocol typically used on Ethernet and token ring LANs.</td>
</tr>
<tr>
<td>UR</td>
<td>Universal relay. A family of GE products, for example B30, F60, and T35.</td>
</tr>
<tr>
<td>WAN</td>
<td>Wide-area network.</td>
</tr>
</tbody>
</table>
# EnerVista Integrator

## Index

| A | Acknowledge event records .............................................................. 38 |
|   | Activation code ......................................................................................... 67 |
|   | Add events for device ................................................................................... 14 |
|   | GE device .................................................................................................. 13 |
|   | generic device ........................................................................................ 22 |
|   | waveform ................................................................................................. 15 |
|   | Alarms add for a device .................................................................................. 14 |
|   | event records .......................................................................................... 38 |
|   | view ............................................................................................................. 37 |
|   | Alert event records ...................................................................................... 38 |
|   | Annunciator event records ........................................................................... 38 |
| B | Back up files ............................................................................................ 64 |
|   | Buttons phasor diagrams ................................................................................. 61 |
|   | waveforms .................................................................................................. 60 |
| C | Changes to document .................................................................................. 71 |
|   | COMTRADE file add for device ....................................................................... 15 |
|   | explained ................................................................................................... 47 |
|   | merge files .................................................................................................. 56 |
|   | resample ..................................................................................................... 59 |
|   | view .............................................................................................................. 49 |
|   | Configuration files back up .......................................................................... 64 |
|   | restore ........................................................................................................ 65 |
|   | Customization of event records displayed .................................................. 38 |
| D | Data harmonics .......................................................................................... 55 |
|   | phasor ......................................................................................................... 54 |
|   | view ........................................................................................................... 54, 55 |
|   | Description of software ................................................................................. 3 |
|   | Device add GE .............................................................................................. 13 |
|   | add generic .................................................................................................. 22 |
|   | event logging ............................................................................................... 36 |
|   | settings ....................................................................................................... 64 |
|   | Device Setup, add device .............................................................................. 13 |
|   | Devices supported ........................................................................................ 4 |
|   | Devices supported, number of ...................................................................... 6, 66 |
|   | Diagram harmonics ..................................................................................... 55 |
|   | phasor ........................................................................................................ 54 |
|   | waveform ................................................................................................... 47 |
| E | EnerVista Integrator does not start .......................................................... 20 |
|   | EnerVista Viewpoint Monitoring .................................................................. 37 |
|   | Error messages, virtual mnemonic ................................................................ 31 |
|   | Event archiving period ................................................................................ 19 |
### Event records
- change default filtering ........................................ 39
- change event type ....................................................... 43
- customize ................................................................... 38
- filter ........................................................................... 38
- refresh ......................................................................... 38
- setup for device ......................................................... 14
- start ........................................................................... 36
- update ......................................................................... 38
- version number ......................................................... 66
- view ............................................................................ 37

### Filter event records .................................................. 38, 39

### Glossary ..................................................................... 73

### Hardware supported .................................................. 4
- Harmonics diagrams .................................................. 55
- Help, technical support .............................................. 1
- Hung services ........................................................... 20

### Installation of EnerVista Integrator ......................... 1

### Import device settings ............................................... 19

### Interface
- phasor diagrams ..................................................... 61
- waveforms ............................................................... 60
- IO Traffic Enabler ................................................... 63

### License ...................................................................... 6
- activation code ....................................................... 67
- number ....................................................................... 66
- transfer ........................................................................ 66
- view ............................................................................ 67

### Logs .......................................................................... 36

### Maximum number of devices
- licenses ..................................................................... 6
- view ............................................................................ 66

### Merge COMTRADE files .......................................... 56

### ML2400 versions supported .................................... 4

### Mnemonics ............................................................... 29

### Modbus memory map .............................................. 22, 64

### Modbus timing ......................................................... 6

### Monitor software ..................................................... 20

### Move software license ............................................ 67

### Number of devices supported
- licenses ..................................................................... 6
- view ............................................................................ 66

### Number of software licenses ................................... 66

### Operations, mathematical ....................................... 29

### Oscilography ............................................................ 47

### Phasor diagrams ..................................................... 54, 61

### Preferences ................................................................ 19
- back up ....................................................................... 64
- event records ............................................................ 38
- event viewer ............................................................. 39
- restore ........................................................................ 65
- time synchronization ................................................ 15
- waveform ................................................................. 51

### Product description ................................................... 3

### Products supported .................................................. 4

### Quickstart Guide ...................................................... 1

### Refresh event records ............................................. 38

### Resample COMTRADE file ...................................... 59

### Restore configuration files ...................................... 65

### Revision history, document .................................... 71

### Safety ........................................................................ 1

### Save configuration files .......................................... 64

### Server status ........................................................... 20
## INDEX

**Settings files**
- back up ............................................................. 64
- preserved when updating software .................. 67
- restore ............................................................... 65

**Slow poll setting** ............................................. 19

**Software**
- activation code .................................................. 67
- does not start ..................................................... 20
- installation ......................................................... 1
- license ............................................................... 6
- number of licenses ............................................. 66
- transfer license ................................................... 67
- uninstall ............................................................ 69
- upgrade ............................................................. 67
- version ............................................................... 66
- view license ......................................................... 66

**Software status** ............................................... 20

**Sort event records** ........................................... 38

**Start servers** ................................................... 20

**Start software** .................................................. 11

**Status** ............................................................. 20

**Stop servers** ..................................................... 20

**Support, technical** ........................................... 1

**Supported hardware** ........................................ 4

**System status** ................................................... 20

## T

**Taskbar icon** .................................................... 20

**Technical support** ............................................. 1

**Terms explained** .............................................. 73

**Third-party waveforms not supported** ............... 47

**Time synchronization** ....................................... 15

**Time-outs** ......................................................... 19

**Timing for Modbus updates** ............................... 6

**Toolbar**
- alarms and events ............................................. 38
- waveforms ......................................................... 60
- Traffic Logger ..................................................... 63
- Transfer software license ................................... 67

**Troubleshooting**
- devices ............................................................. 63
- software start .................................................... 20
- technical support .............................................. 1

## U

**Uninstall software** ............................................ 69

**Update event records** ...................................... 38

**Upgrade, software** ........................................... 67

**UR versions supported** ..................................... 4

**User-friendly names** ........................................ 29

## V

**Version, software** ............................................ 66

---

**W**

**Waveform window explained** .......................... 50

**Waveforms**
- COMTRADE file explained ............................... 47
- enable device ..................................................... 48
- event records ..................................................... 38
- explained ......................................................... 47
- harmonics diagrams ....................................... 55
- interface ......................................................... 61
- merge COMTRADE files ................................... 56
- phasor diagrams .............................................. 54, 61
- preferences ..................................................... 51
- resample COMTRADE file ............................... 59
- start server ..................................................... 48
- third-party not supported ............................... 47
- view COMTRADE file ...................................... 49