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Overview of Functionality:
NET Connectivity Window Overview:

· Monitor the status of MDS’ iNET 900, iNET-II, and entraNET 900 radios.

· Provides a data logging feature to allow for the logging of radio performance data.

· Provides GPS Features to log GPS related data.

· Designed to function in a mobile environment where the laptop PC is locally connected to an MDS remote via the Ethernet port.   
entraNET Monitoring Window Features:

· Monitors the connectivity status, traffic history, and RSSI values for entraNET 900 remote radios. 

· RSSI and state of association are graphically displayed to the entraNET Monitoring Window.

iNET Monitoring Window Features:

· Monitors the connectivity status, RSSI, and traffic history for iNET 900 and iNET-II remote radios. 
· RSSI and state of association are graphically displayed to the iNET Monitoring Window. 

Installation & Setup:

Installation: 

Download program zip file and unzip all files.  After all files have been extracted, double-click on the NET Connectivity Window setup file.  This will launch the NET Connectivity Window installation.  Follow the instructions on the prompts.  

Launching the NET Connectivity Window: 

There are two ways to launch the NET Connectivity Window:

1) Double-click on the application icon on the Desktop or within the Start menu (Start ( Programs ( Microwave Data Systems ( NET Connectivity Window ( NET Connectivity Window.exe)

2) Click on the application icon named ‘NET Connectivity Window.exe’ located in: 
C:\Program Files\Microwave Data Systems\NET Connectivity Window\ 

NET Connectivity Window: Overview
tc "entraNET Monitoring Window\: Overview"

"
The NET Connectivity Window is a Windows-based software application designed to facilitate the mobile monitoring of MDS' iNET 900, iNET-II, and entraNET 900 radios.
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Note: The NET Connectivity Window application is designed to work in a mobile environment where the laptop PC is locally connected to an iNET 900, iNET-II, or entraNET 900 remote via the Ethernet port.

xe "Step by Step Operating Instructions" NET Connectivity Window: 

Step by Step Operating Instructions
tc "entraNET Monitoring Window\: Overview"
1.
Start the NET Connectivity Window by double-clicking the icon.

2.
Select the desired type of remote to be monitored.

· If the entraNET 900 remote is selected for monitoring, the user will be required to enter a valid     Destination Port for receiving UDP datagram packets from the entraNET remote. The Destination port is a number between 30,000 and 60,000. In addition, the Destination port entered for the application must match the port set in the remote with the STATTRACKER PORT=<range integer> command.
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Figure 1. Remote selection
· If the iNET 900 or iNET-II remote is selected for monitoring, the user will be required to select a valid IP address for the iNET remote from the drop down menu. If the desired remote's IP address has not been added to the drop down menu, the user can add the IP address by selecting the "Add IP Address" item from the drop down menu. A field will appear where the new IP address can be entered. The SNMP Read Community String property can be modified by selecting the Network Options item from the Options menu.
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Figure 2a. Selection of remote's IP Address
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Figure 2b. Entering a new IP Address
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Figure 2c. Network Options: Modifying the SNMP Read Community String

3.
To customize the data logging feature, choose the Options menu on the initial NET Connectivity Window screen followed by the Log Options menu. The Enable Logging menu item can be clicked to set the logging feature to be enabled or disabled; a check mark adjacent to the menu item confirms that the data logging feature is enabled. Additionally, when the data logging feature has been enabled, the user can modify the filename of the file if desired. To modify the filename, choose the Save File As item on the Log Options menu. A Save As dialog box will prompt the user to enter a valid filename and location for storage.
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Figure 3a. Enabling the data logging feature
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Figure 3b. Saving the data log file
4. To customize the GPS Options, choose the Options menu on the initial NET Connectivity Window screen followed by the GPS Options item. The GPS Options window will appear, allowing the user to enable or disable the GPS feature, as well as select a serial port for communications with the GPS Device in use. When the GPS feature has been enabled, GPS information will be logged in the data log file, if the user has enabled the data logging feature.

[image: image36.png]- - = 1=

(v o nccooror [ _amar
| 3]  Network Places B somta
T Donerropre

e Tronton o3
WeTontonng Log

Choose aLog

=

Shortcut to My Documents

Hotetue .| ey =
E e I

4





Figure 4a. Selecting the GPS Options item within the Options menu
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Figure 4b. Enabling the GPS Feature within the GPS Options Window


5. To start the monitoring process for the remote selected, select OK. 

eNET Monitoring Window: Overview
tc "entraNET Monitoring Window\: Overview"
The eNET Monitoring Window is a Windows-based software application designed to facilitate the monitoring of connectivity status and RSSI values for entraNET remote radios. The entraNET remote broadcasts the RSSI and state of association (associated or disconnected) to the eNET Monitoring Window. The information is then graphically displayed to the user. 
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Figure 1. Monitoring for the entraNET 900 remote
Note: The eNET Monitoring Window application is designed to work in a mobile environment where the laptop PC is locally connected to an entraNET remote via the Ethernet port.

eNET Monitoring Window: 

Step by Step Operating Instructions

1.
Start the NET Connectivity Window by double-clicking the icon.

2.
Select MDS' entraNET 900 as the type of remote to be monitored.
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Figure 1. Selecting the entraNET 900 as the remote to be monitored
3.
Enter a valid Destination port for receiving UDP datagram packets from the entraNET remote. The Destination port is a number between 30,000 and 60,000. In addition, the Destination port entered for the application must match the port set in the remote with the STATTRACKER PORT=<range integer> command.

4.
To customize the data logging feature, choose the Options menu on the initial NET Connectivity Window screen followed by the Log Options menu. The Enable Logging menu item can be clicked to set the logging feature to be enabled or disabled; a check mark adjacent to the menu item confirms that the data logging feature is enabled. Additionally, when the data logging feature has been enabled, the user can modify the filename of the file if desired. To modify the filename, choose the Save File As item on the Log Options menu. A Save As dialog box will prompt the user to enter a valid filename and location for storage.

[image: image38.png]EETTEE——— -loix

Fle Vew Hep

Connection Status ‘ Associated

Signal Strength

100 dBm 0 dbm T





Figure 2a. Enabling the data logging feature
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Figure 2b. Saving the data log file

5. To customize the GPS Options, choose the Options menu on the initial NET Connectivity Window screen followed by the GPS Options item. The GPS Options window will appear, allowing the user to enable or disable the GPS feature, as well as select a serial port for communications with the GPS Device in use. When the GPS feature has been enabled, GPS information will be logged in the data log file, if the user has enabled the data logging feature. 
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Figure 3a. Selecting the GPS Options item within the Options menu
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Figure 3b. Enabling the GPS Feature within the GPS Options Window

6.
Select 'OK' to begin monitoring.
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Figure 4. Monitoring for the entraNET 900 remote

eNET Monitoring Window: Monitoring

"
Monitoring is started automatically when a valid destination port has been entered.  Upon connecting to an entraNET 900 remote, the monitoring process continually runs.  On a scheduled interval, the current RSSI is obtained from the remote and logged on the hard drive as data in a tab-delimited text file.

[image: image42.png]L s tdem | the RSt Theesheld ol x| =loix
Fie fun Options |

Current RSSI Threshold:

—98 dBm
Connection S
Received Sigl Enter new RSS! Thieshold: [ gBm
(RSSI)

oo |





Figure 1. Monitoring for the entraNET 900 remote

eNET Monitoring Window: Data Logging


xe "entraNET Monitoring Window\: Data Logging" 


"
On a scheduled interval, various information is obtained from the remote and logged on the hard drive as data in a tab-delimited text file. This information includes: date, time, RSSI, RX Bytes, RX Packets, RX Errors, TX Bytes, TX Packets, TX Errors, Fragments, and Retries. If the user has enabled the GPS feature the log file will also include the following GPS information: latitude, longitude, fix quality, number of satellites tracked, horizontal dilution, and altitude.
To change the file that the information is being logged to, select the Options pulldown menu followed by the Log Options menu.  This can be seen below.  
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Figure 1. Enabling the Data Logging Feature
The Enable Logging menu item can be clicked to set the logging feature to be enabled or disabled; a check mark adjacent to the menu item confirms that the data logging feature is enabled. Additionally, when the data logging feature has been enabled, the user can modify the filename of the file if desired. To modify the filename, choose the Save File As item on the Log Options menu. A Save As dialog box will prompt the user to enter a valid filename and location for storage.
 xe "entraNET Monitoring Window\: GPS Options"eNET Monitoring Window: GPS Options 


"
The NET Connectivity Window also allows for the logging of GPS data, if it is desired. If the feature is enabled, the application will log GPS information, such as latitude and longitude, to the data logging file, if the data logging feature has been enabled. If the user has enabled the GPS feature the log file will also include the following GPS information: latitude, longitude, fix quality, number of satellites tracked, horizontal dilution, and altitude.
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To customize the GPS Options, choose the Options menu on the initial NET Connectivity Window screen followed by the GPS Options item. The GPS Options window will appear, allowing the user to enable or disable the GPS feature, as well as select a serial port for communications with the GPS Device in use. 

Figure 1a. Selecting the GPS Options item within the Options menu
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Figure 1b. Enabling the GPS Feature within the GPS Options Window

xe "entraNET Monitoring Window Help"xe "entraNET Monitoring Window\: Monitoring"eNET Monitoring Window: Traffic History 
"





"
The Traffic History feature displays data bytes sent and received within a chart. This feature can be turned on or off; to do so select Traffic History in the View menu within the Options pull-down menu. 
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Figure 1. Enabling the Traffic History Feature

[image: image45.png][0 szm -

Fle fun Opbons e

Connection Status ‘ Associated
Received Signal Strength
(RSSI)
100%m & &0
Tt ity Char.

= % MaxData Received
= % Max Data Transmited

s

<

5
N
2
o

Wewtes.





Figure 2. Monitoring for the entraNET 900 remote with the Traffic History feature

enabled
eNET Monitoring Window:  Troubleshooting


"
   
	Problem
	Solution

	Error message appears prompting for the entry of a valid number in the Destination Port field.
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	Enter a number between 30,000 and 60,000 in the Destination Port field which matches the Port value set by the STATTRACKER PORT = <range integer> within the remote.

	Program ends citing that a connection could not be established. Possible causes for the error include a disconnected remote or an invalid Destination Port.
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	1.   Check to see that the remote is plugged in and set up appropriately.

2.   Ensure that the number entered in the Destination Port field matches the Port value set within the remote.

3.   Restart the radio and try again.



	Application shows that the remote is disconnected and is not receiving data from the remote, and therefore does not give an RSSI reading.
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	1.   Ensure that the remote is set up and plugged in appropriately.

2.   Restart the radio and try again. 

	The program has timed out because data has not been received from the remote for a specified amount of time.
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	1.   Ensure that the remote is set up and plugged in appropriately.

2.   Restart the radio and try again. 
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	1. This error occurs when another application is using the serial port selected for communication with the GPS device.

2. Find the alternate application that is using the chosen serial port and close that connection.

3. Restart the NET Connectivity Window and try again.




iNET Monitoring Window: Overviewtc "iNET Monitoring Window\: Overview"
The iNET Monitoring Window is a Windows-based software application designed to monitor the connectivity status, RSSI, and traffic history for iNET 900 and iNET-II remote radios.  The iNET Monitoring Window periodically polls a locally connected iNET remote to determine the RSSI level, as well as the state of association (associated, scanning, or connecting). The information is then graphically displayed to the user as shown below. The RSSI Threshold setting is displayed as a black line in the color bar. If the threshold is not set in the iNET radio, it will be shown as below (-100 dBm).


Figure 1. Monitoring for the iNET 900 or iNET-II remote
Note:The iNET Monitoring Window application is designed to work in a mobile environment where the laptop PC is locally connected to an iNET remote via the Ethernet port.
iNET Monitoring Window: 

STEP BY STEP OPERATING INSTRUCTIONS


"

1.
Start the NET Connectivity Window by double-clicking the icon.

2.
Select MDS' iNET 900 or iNET-II as the type of remote to be monitored.



Figure 1. Selecting the iNET 900 as the remote to be monitored
3.
Select a valid IP Address for the iNET remote being used from the drop down menu. If you wish to enter a new IP Address, select the Add IP Address item from the drop down menu. A field will appear where the new IP Address is to be entered.


Figure 2a. Selecting an IP Address for the iNET 900 remote

Figure 2b. Entering a new IP Address for the iNET-II remote
4.
To customize the data logging feature, choose the Options menu on the initial NET Connectivity Window screen followed by the Log Options menu. The Enable Logging menu item can be clicked to set the logging feature to be enabled or disabled; a check mark adjacent to the menu item confirms that the data logging feature is enabled. Additionally, when the data logging feature has been enabled, the user can modify the filename of the file if desired. To modify the filename, choose the Save File As item on the Log Options menu. A Save As dialog box will prompt the user to enter a valid filename and location for storage.
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Figure 3a. Enabling the data logging feature


Figure 3b. Saving the data log file

5. To customize the Network Options, choose the Options menu on the initial NET Connectivity Window sceen, followed by the Network Options item. The Network Options window will appear, allowing the user to modify the settings for the SNMP Community Read and Write strings.


Figure 4a. Selecting the Network Options menu item

Figure 4b. Modifying the Network Options settings

6. To customize the GPS Options, choose the Options menu on the initial NET Connectivity Window screen followed by the GPS Options item. The GPS Options window will appear, allowing the user to enable or disable the GPS feature, as well as select a serial port for communications with the GPS Device in use. When the GPS feature has been enabled, GPS information will be logged in the data log file, if the user has enabled the data logging feature.


Figure 5a. Selecting the GPS Options item within the Options menu
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Figure 5b. Enabling the GPS Feature within the GPS Options Window
7.
Select 'OK' to begin monitoring.


Figure 6. Monitoring for the iNET 900 or iNET-II remote
iNET Monitoring Window: Monitoringtc "iNET Monitoring Window\: Monitoring"
Monitoring is started automatically when a correct remote IP Address has been entered.  Upon connecting to an iNET 900 or iNET-II remote, the monitoring process continually runs.  On a scheduled interval, the current RSSI, association status, and IP Address of the Acess Point are obtained from the remote and logged on the hard drive as data in a tab-delimited text file.


Figure 1. Monitoring for the iNET 900 or iNET-II remote
xe "iNET Monitoring Window\: Data Logging"iNET Monitoring Window: Data Loggingtc "iNET Monitoring Window\: Data Logging"
On a scheduled interval, various information is obtained from the remote and logged on the hard drive as data in a tab-delimited text file. This information includes: date, time, RSSI, and the IP Address of the AP, as well as performance statistics for the iNET remote radio. The performance statistics logged include: RX bytes, RX packets, RX errors, TX bytes, TX packets, TX errors, retries and retry errors. If the user has enabled the GPS feature the log file will also include the following GPS information: latitude, longitude, fix quality, number of satellites tracked, horizontal dilution, and altitude.
To change the file that the information is being logged to, select the Options pulldown menu followed by the Log Options menu.  This can be seen below.  


Figure 1. Enabling the Data Logging Feature

The Enable Logging menu item can be clicked to set the logging feature to be enabled or disabled; a check mark adjacent to the menu item confirms that the data logging feature is enabled. Additionally, when the data logging feature has been enabled, the user can modify the filename of the file if desired. To modify the filename, choose the Save File As item on the Log Options menu. A Save As dialog box will prompt the user to enter a valid filename and location for storage.
xe "iNET Monitoring Window\: GPS Options" iNET Monitoring Window: GPS Optionstc "iNET Monitoring Window\: Data Logging"

"
The NET Connectivity Window also allows for the logging of GPS data, if it is desired. If the feature is enabled, the application will log GPS information, such as latitude and longitude, to the data logging file, if the data logging feature has been enabled. If the user has enabled the GPS feature the log file will also include the following GPS information: latitude, longitude, fix quality, number of satellites tracked, horizontal dilution, and altitude.
To customize the GPS Options, choose the Options menu on the initial NET Connectivity Window screen followed by the GPS Options item. The GPS Options window will appear, allowing the user to enable or disable the GPS feature, as well as select a serial port for communications with the GPS Device in use. 


Figure 1a. Selecting the GPS Options item within the Options menu
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Figure 1b. Enabling the GPS Feature within the GPS Options Window
xe "iNET Monitoring Window\: Modifying Settings" iNET Monitoring Window: Modifying Settingstc "iNET Monitoring Window\: Data Logging"

"
The iNET Monitoring Window allows the user to modify the RSSI Threshold as well as the SNR Threshold, if it is desired. These settings take effect on both the visual color bars within the application as well as within the settings of the actual radio.
NOTE: In order for the changes to the settings to be updated correctly within the radio, you must ensure that the SNMP Read Community String and the SNMP Write Community String settings within the application match the settings within the remote radio. To check the settings within the application, 
The  RSSI Threshold value is displayed on the RSSI status bar as the black line within the colored RSSI bar. Likewise, the SNR Threshold value is displayed on the SNR status bar as the black line within the colored SNR bar.


Figure 1. Display of RSSI Threshold and SNR Threshold within the iNET Monitoring Window

To modify the settings for the RSSI Threshold or the SNR Threshold, select either the Change RSSI Threshold or Change SNR Threshold menu items within the Options menu. A window will then appear prompting the user to enter a new value for the desired threshold modification.


xe "iNET Monitoring Window\: Monitoring"
Figure 2. Modifying the RSSI Threshold

Figure 3. Modifying the SNR Threshold 

xe "iNET Monitoring Window\: Network Options" iNET Monitoring Window: Network Optionstc "iNET Monitoring Window\: Data Logging"

"
Network Options can be initialized on the first NET Connectivity Window screen that is displayed when the program is run. Network Options include settings for the SMNP Community read and write strings.

The SNMP Community read and write strings must be initialized to match the settings within the actual remote radio in order to correctly utilize the features which allow for the modification of the SNR Threshold and the RSSI Threshold.

To access the Network Options window, use the Options pull-down menu, and select the Network Options item. The Network Options window will appear, allowing for the customization of the SNMP Community Read and Write Strings.


Figure 1. Selecting the Network Options menu item
xe "iNET Monitoring Window\: Overview"

Figure 2. Modifying the Network Options settings
xe "iNET Monitoring Window\: SNR Status"iNET Monitoring Window: SNR Statustc "iNET Monitoring Window\: Data Logging"

"
 tc "iNET Monitoring Window\: SNR Status"
The SNR Status feature displays the status of the SNR (Signal to Noise Ratio). This feature can be turned on or off; to do so select SNR Status Bar in the View menu within the Options pull-down menu. 
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Figure 1. Enabling the SNR Status Feature
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Figure 2a. Monitoring for the iNET 900 and iNET-II remote with the SNR Status feature enabled


Figure 2b. Monitoring for the iNET 900 and iNET-II remote with the SNR Status and the Traffic History features enabled
xe "iNET Monitoring Window\: STEP BY STEP OPERATING INSTRUCTIONS"

xe "iNET Monitoring Window\: Traffic History" iNET Monitoring Window: Traffic Historytc "iNET Monitoring Window\: Data Logging"

"

The Traffic History feature displays data bytes sent and received within a chart. This feature can be turned on or off; to do so select Traffic History in the View menu within the Options pull-down menu. 
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Figure 1. Enabling the Traffic History Feature


Figure 2. Monitoring for the iNET 900 and iNET-II remote with the Traffic History feature enabled
xe "iNET Monitoring Window\: Troubleshooting" iNET Monitoring Window: Troubleshootingtc "iNET Monitoring Window\: Data Logging"

"

The Traffic History feature displays 

"

	Problem
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	1. Select OK on the error message.

2. Enter a correct IP address for the desired iNET remote on the NET Connectivity Window screen.
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	1. Select OK on the error message.

2. Reboot the iNET remote. Wait 2 minutes, and restart the monitoring application by selecting "Resume Monitoring" from the Run menu.

3. If the application is still unable to communicate with the remote radio, perform the following steps:
4. Verify the correctness of the IP Address entered on the initial screen. 

5. Verify that the iNET remote has been set up for a mobile environment.

6. Exit the application and restart.
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	                          1. Select OK on the error message.

                                 2. Enter an RSSI Threshold value                                       between 0 and -120 into the text                                         field on the Change RSSI Threshold                                  window.
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	 1. Select OK on the error message.

2. Enter an SNR Threshold value                                between 0 and 40 into the text                                            field on the Change SNR Threshold                                  window.

	The SNR and RSSI Threshold values do not update correctly, and the iNET remote will not reboot correctly.


	1. Exit the application.

2. Restart the application and ensure that the SNMP Community read/write strings in the Network Options match those in the iNET remote.
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